Bug 463318 - [LTC 6.0 FEAT] 201572:Python scripting support in GDB
[LTC 6.0 FEAT] 201572:Python scripting support in GDB
Status: CLOSED DUPLICATE of bug 463317
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gdb (Show other bugs)
6.0
ppc64 All
medium Severity medium
: alpha
: 6.0
Assigned To: Jan Kratochvil
: FutureFeature, OtherQA
Depends On:
Blocks: 356741
  Show dependency treegraph
 
Reported: 2008-09-22 17:30 EDT by IBM Bug Proxy
Modified: 2009-12-18 14:41 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-18 14:41:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2008-09-22 17:30:50 EDT
=Comment: #0=================================================
Emily J. Ratliff <emilyr@us.ibm.com> - 2008-09-16 18:28 EDT
1. Feature Overview:
Feature Id:	[201572]
a. Name of Feature:	Python scripting support in GDB
b. Feature Description
Support extending GDB functionality or automating it using Python scripts. The GDB community is
currently working on exposing a GDB API to Python scripts, and execute them with a Python
interpreter embedded in GDB. This will most probably appear in the next GDB release after 6.8.

2. Feature Details:
Sponsor:	PPC
Architectures:
x86
x86_64
ppc64

Arch Specificity: Purely Common Code
Affects Toolchain: Yes
Delivery Mechanism: Direct from community
Category:	Toolchain
Request Type:	Toolchain - Enhancement from Upstream
d. Upstream Acceptance:	In Progress
Sponsor Priority	2
f. Severity: Medium
IBM Confidential:	no
Code Contribution:	3rd party code
g. Component Version Target:	the next GDB release after 6.8

3. Business Case
Being able to extend GDB using a powerful API exposed to Python scripts will provide more
flexibility for IBM to support RAS requirements in its middleware applications. For example, the IBM
Java (or Domino, or Tivoli) team will be able to provide an extension script which can collect and
interpret specific JVM information for failure data capture.

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Michael Hohnbaum, hbaum@us.ibm.com, 503-578-5486

Technical contact(s):
Thiago Jung Bauermann, thiagoju@br.ibm.com

IBM Manager:
Alexander Johnson, acjohnso@us.ibm.com
Comment 1 Bill Nottingham 2008-10-02 11:38:54 EDT
Any reason this shouldn't be marked as a dup of 463317?
Comment 2 IBM Bug Proxy 2008-10-03 11:46:53 EDT
I opened a specific feature for python because I thought it could give better coverage if we need something for python which for some reason doesn't get into the next gdb version (even though we are striving to get it all upstream). If you think this is not necessary (since 463317 mentions python as well), this can be duped.
Comment 3 Bill Nottingham 2008-10-03 11:54:31 EDT
Ah, ok. Wasn't sure if it was something that was already in upstream for post-6.8 or not.
Comment 4 IBM Bug Proxy 2009-03-02 20:51:07 EST
Python scripting support is present in the Archer code going into Fedora 11, so I believe I don't need to post patches here...
Comment 5 Jan Kratochvil 2009-09-18 12:19:35 EDT
There is already gdb-6.8.91.20090917-2.fc12 for F12 as a FSF GDB 7.0 candidate.
Python support is present with extension from the Archer branch.
Suggesting devel_ack+.
Comment 7 John Jarvis 2009-12-14 09:49:56 EST
IBM is signed up to test and provide feedback.
Comment 8 John Jarvis 2009-12-18 14:41:12 EST
Duping this to BZ 463317 which requests the GDB update.

*** This bug has been marked as a duplicate of bug 463317 ***

Note You need to log in before you can comment on or make changes to this bug.