Bug 463324 - @base installs require lzma for man to work
@base installs require lzma for man to work
Status: CLOSED DUPLICATE of bug 461775
Product: Fedora
Classification: Fedora
Component: man (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Blocker/F10FinalBlocker
  Show dependency treegraph
 
Reported: 2008-09-22 17:49 EDT by Will Woods
Modified: 2013-01-09 23:48 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-23 02:13:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Will Woods 2008-09-22 17:49:11 EDT
man now supports lzma-compressed manpages. That's fine, but lzma is not in @base, so installing just @base results in a system which cannot run man.

Suggest adding lzma to the @base group.
Comment 1 Jesse Keating 2008-09-22 18:28:05 EDT
Are all man pages made in lzma now, or only some?  Are you getting a crash or an error?  Would this be better solved by a package requirement rather than a comps forcing?
Comment 2 Will Woods 2008-09-22 18:57:04 EDT
AFAICT man saves its cached pages in lzma format now. Or it tries to.

The strange part is - this only happens when I'm logged in at the console. The error is:

sh: /usr/bin/lzma: No such file or directory
Error executing formatting or display command.
System command (cd /usr/share/man && (echo ".pl 1100i"; /usr/bin/gunzip -c '/usr/share/man/man1/ls.1.gz'; echo ".\\\""; echo ".pl \n(nlu+10") | /usr/bin/gtbl | /usr/bin/nroff -c -mandoc 2>/dev/null | /usr/bin/lzma > /var/cache/man/cat1/ls.1.lzma) exited with status 32512.

Yes, you could also fix this by making man require lzma.
Comment 3 Jesse Keating 2008-09-22 19:10:14 EDT
Fixing it with requires seems like the right thing to do, especially for people who install and fiddle with groups or whatnot.  If man is going to use it, it needs to require it.
Comment 4 Ivana Varekova 2008-09-23 02:13:02 EDT

*** This bug has been marked as a duplicate of bug 461775 ***

Note You need to log in before you can comment on or make changes to this bug.