Bug 461775 - man needs lzma, but not getting installed
man needs lzma, but not getting installed
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: man (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
Fedora Extras Quality Assurance
:
: 461842 463324 463941 (view as bug list)
Depends On:
Blocks: F10Blocker/F10FinalBlocker
  Show dependency treegraph
 
Reported: 2008-09-10 10:43 EDT by Jerry Williams
Modified: 2008-09-25 12:18 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-12 08:50:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
man,config (4.82 KB, text/plain)
2008-09-12 04:29 EDT, Hans de Goede
no flags Details

  None (edit)
Description Jerry Williams 2008-09-10 10:43:04 EDT
Description of problem: man yum fails on default install because lzma isn't installed.


Version-Release number of selected component (if applicable):
man-1.6f-9.fc10.i386


How reproducible: Always


Steps to Reproduce:
1. Do default install of F10a, been unchecking dial up and office and java
2. man yum
3.
  
Actual results:
# man yum
Formatting page, please wait...
sh: /usr/bin/lzma: No such file or directory
Error executing formatting or display command.
System command (cd /usr/share/man && (echo ".pl 1100i"; /usr/bin/gunzip -c '/usr/share/man/man8/yum.8.gz'; echo ".\\\""; echo ".pl \n(nlu+10") | /usr/bin/gtbl | /usr/bin/nroff -c -mandoc 2>/dev/null | /usr/bin/lzma > /var/cache/man/cat8/yum.8.lzma) exited with status 32512.



Expected results:
Show man page

Additional info:

yum install lzma
Installed: lzma.i386 0:4.32.7-1.fc10
Dependency Installed: lzma-libs.i386 0:4.32.7-1.fc10

man yum works great!

jlaska	perhaps a bug requesting that `man` adds a %requires lzma to it's spec file might be in order
Comment 1 Ivana Varekova 2008-09-12 03:18:49 EDT
Hello, please could you attach here your /etc/man.config file?
Comment 2 Ivana Varekova 2008-09-12 04:12:00 EDT
The problem should be you either change /etc/man.config setting  or you have an environment variable PAGER set to /usr/bin/lzma.
So please put here printenv | grep PAGER too.
Comment 3 Ivana Varekova 2008-09-12 04:13:22 EDT
*** Bug 461842 has been marked as a duplicate of this bug. ***
Comment 4 Hans de Goede 2008-09-12 04:28:01 EDT
Sorry about the duplicate.

About your questions regarding man.config and PAGER, PAGER is not set. man.config is unchanged from as it is in the rpm (man-1.6f-9.fc10.i386), never the less I'll attach it for you.
Comment 5 Hans de Goede 2008-09-12 04:29:23 EDT
Created attachment 316546 [details]
man,config
Comment 6 Hans de Goede 2008-09-12 04:31:20 EDT
Checking the attached man.config you will see it specifies lzma, which explains why man needs lzma now, maybe the upstream defaults have changed?

Anyways the fix is to either change the default config as it installed with a fresh install, or to add a "Requires: /usr/bin/lzma" to the package.

Note I verified that this man.config is unchanged from the one in the rpm using rpm --verify
Comment 7 Ivana Varekova 2008-09-12 08:50:22 EDT
Thanks. Fixed in man-1.6f-10.fc10.i386
Comment 8 Ivana Varekova 2008-09-23 02:13:02 EDT
*** Bug 463324 has been marked as a duplicate of this bug. ***
Comment 9 Will Woods 2008-09-25 12:18:28 EDT
*** Bug 463941 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.