Bug 463365 - [LTC 6.0 FEAT] 200974:Kernel interface to performance monitor unit
[LTC 6.0 FEAT] 200974:Kernel interface to performance monitor unit
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
ppc64 All
high Severity high
: alpha
: 6.0
Assigned To: Steve Best
Red Hat Kernel QE team
: FutureFeature
Depends On:
Blocks: 356741 463369 463372 RHEL6Kernel2.6.27 554559
  Show dependency treegraph
 
Reported: 2008-09-22 23:00 EDT by IBM Bug Proxy
Modified: 2010-11-11 09:41 EST (History)
8 users (show)

See Also:
Fixed In Version: kernel-2.6.31-1
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-11 09:41:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2008-09-22 23:00:20 EDT
=Comment: #0=================================================
Emily J. Ratliff <emilyr@us.ibm.com> - 2008-09-16 18:29 EDT
1. Feature Overview:
Feature Id:	[200974]
a. Name of Feature:	Perfmon2 kernel interface to PMU
b. Feature Description
Perfmon2 is the new (converged) 'hardware-based performance monitoring interface for Linux' kernel.
 It is an open source project whose maintainer is Stephan Eranian from HP.  There's been increasing
interest in getting a standard kernel interface to performance monitor units (PMUs) into mainline
kernel, and Perfmon2 appears to have the necessary community support.  Not in mainline yet, but
Andrew Morton wants to see a push to get it in.

2. Feature Details:
Sponsor:	PPC
Architectures:
ppc64

Arch Specificity: Both
Affects Core Kernel: Yes
Delivery Mechanism: Direct from community
Category:	Toolchain
Request Type:	Toolchain - Enhancement from Upstream
d. Upstream Acceptance:	Submitted
Sponsor Priority	2
f. Severity: Medium
IBM Confidential:	no
Code Contribution:	IBM code
g. Component Version Target:	2.6.27

3. Business Case
Performance analysis tools rely on a kernel interface to the PMU.  OProfile has the oprofile kernel
driver already in mainline, but other tools (e.g., PAPI) rely on various non-mainline PMU interface
software that must be patched into the kernel.  This reliance on non-mainline kernel code has
prevented including PAPI (and possibly other tools) in the distros.  Including PAPI in the distros
would be beneficial, especially to the high performance computing community where PAPI is very popular.

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Michael Hohnbaum, hbaum@us.ibm.com, 503-578-5486

Technical contact(s):
Steven Munroe, sjmunroe@us.ibm.com
Maynard Johnson, mpjohn@us.ibm.com

IBM Manager:
Alexander Johnson, acjohnso@us.ibm.com
Comment 1 Bill Nottingham 2008-10-02 12:18:51 EDT
This has a target of 2.6.27 set, but as I understand it, perfmon2 is *not* actually in 2.6.27. Correct?
Comment 2 IBM Bug Proxy 2008-10-02 12:39:14 EDT
Correct.  Perfmon2 did not make it into 2.6.27.  Outlook is uncertain as to what kernel version this will be accepted into.  We are actively working with the community to gain mainline acceptance.
Comment 3 IBM Bug Proxy 2009-08-31 15:51:05 EDT
------- Comment From mpjohn@us.ibm.com 2009-08-31 15:40 EDT-------
Hello, Red Hat,
I changed the summary description of this feature request to:
"Kernel interface to performance monitor unit"
Please change the summary description on the Red Hat side as well.

This generic feature description allows for the more likely case that the "Performance Counters for Linux" interface (aka "perf_counters" or "PCL") will be included in RHEL 6, since it's been accepted into mainline and will be included in 2.6.31.  PCL would satisfy this feature request.  Thank you.

------- Comment From mpjohn@us.ibm.com 2009-08-31 15:44 EDT-------
No patch is attached to this bugzilla, on the assumption that RHEL 6 will be based on a kernel version that includes PCL.
Comment 4 Bill Nottingham 2009-09-01 17:59:44 EDT
OK, setting to MODIFIED based on the PCL comment.

The feature requested has already been accepted into the upstream code base
planned for the next major release of Red Hat Enterprise Linux.

When the next milestone release of Red Hat Enterprise Linux 6 is available,
please verify that the feature requested is present and functioning as
desired.
Comment 5 Siddharth Nagar 2009-10-23 10:01:17 EDT
PCL will be included in RHEL 6 in lieu of perfmon2.
Comment 7 IBM Bug Proxy 2010-04-27 14:41:20 EDT
------- Comment From mpjohn@us.ibm.com 2010-04-27 14:34 EDT-------
I've verified this feature is present in RHEL6 beta1.  Thank you.
Comment 8 Boris Ranto 2010-06-09 07:09:49 EDT
Verified in 2.6.32-25.el6.ppc64. The feature is present.
Comment 9 releng-rhel@redhat.com 2010-11-11 09:41:33 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.