Bug 463369 - [LTC 6.0 FEAT] 200977:PAPI runtime and development
[LTC 6.0 FEAT] 200977:PAPI runtime and development
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: distribution (Show other bugs)
6.0
ppc64 All
high Severity high
: alpha
: 6.0
Assigned To: Steve Best
Ben Levenson
: FutureFeature, OtherQA
Depends On: 463365
Blocks: 356741 532993 554559
  Show dependency treegraph
 
Reported: 2008-09-22 23:10 EDT by IBM Bug Proxy
Modified: 2010-07-12 08:42 EDT (History)
6 users (show)

See Also:
Fixed In Version: papi-3.7.2-4.el6
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-12 08:42:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2008-09-22 23:10:45 EDT
=Comment: #0=================================================
Emily J. Ratliff <emilyr@us.ibm.com> - 2008-09-16 18:30 EDT
1. Feature Overview:
Feature Id:	[200977]
a. Name of Feature:	PAPI runtime and development
b. Feature Description
The Performance API (PAPI) project specifies a standard application programming interface (API) for
accessing hardware performance counters available on most modern microprocessors.  This feature is
dependent on feature 200974.

Additional Comments:	papi is at http://icl.cs.utk.edu/papi/index.html

2. Feature Details:
Sponsor:	PPC
Architectures:
ppc64

Arch Specificity: Both
Delivery Mechanism: Direct from community
Category:	Toolchain
Request Type:	Package - New
d. Upstream Acceptance:	Accepted
Sponsor Priority	2
f. Severity: Medium
IBM Confidential:	no
Code Contribution:	IBM code
g. Component Version Target:	papi 3.6 (or later)

3. Business Case
The PAPI tool is used to collect performance data in large clustered environments.

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Michael Hohnbaum, hbaum@us.ibm.com, 503-578-5486

Technical contact(s):
Steven Munroe, sjmunroe@us.ibm.com
Maynard Johnson, mpjohn@us.ibm.com

IBM Manager:
Alexander Johnson, acjohnso@us.ibm.com
Comment 1 Bill Nottingham 2008-10-02 12:26:53 EDT
Marking as dependent on perfmon2.
Comment 2 IBM Bug Proxy 2009-08-31 18:31:02 EDT
------- Comment From mpjohn@us.ibm.com 2009-08-31 18:28 EDT-------
This PAPI feature depends on a kernel interface to the performance monitoring hardware.  Such an interface is the topic of another IBM feature request for RHEL 6 -- IBM bug # 48182, RH # 463365.  As stated there, the original plan was to include perfmon2 in RHEL 6 since perfmon2 seemed to be on track for probable acceptance into the kernel at that time.  But in late 2008, an alternative kernel interface to PM hardware was proposed ("Performance Counters for Linux", aka "PCL").  The implementation for this new interface has now been accepted into the kernel.  A new "PCL" substrate was required to enable PAPI to function on top of PCL versus perfmon2.  We have contributed such a substrate to the PAPI project, and it was accepted on July 13, 2009.

As of this date, the PCL support in PAPI is not yet available in an official release.  Assuming the PCL feature is accepted (RH # 463365), then a PAPI CVS snapshot from some date after 07/13/2009 should be used for building the PAPI package for RHEL 6.

Thank you.
Comment 5 John Jarvis 2009-11-12 14:52:15 EST
The package will be available in beta 1.
Comment 6 IBM Bug Proxy 2009-11-29 22:30:26 EST
------- Comment From mpjohn@us.ibm.com 2009-11-29 22:28 EDT-------
Changing status to ACCEPTED based on previous comment from Red Hat.
Comment 7 John Jarvis 2009-11-30 11:29:13 EST
IBM is signed up to test and provide feedback.
Comment 9 Kevin W Monroe 2009-12-01 17:10:48 EST
Reassigning to Steve Best, the new IBM on-site partner.
Comment 10 William Cohen 2009-12-17 10:09:31 EST
The performance event support is in the 2.6.31 and newer kernel. PAPI-3.7 and newer versions of PAPI have support for the Linux Performance Event Support. PAPI-3.7.2 has been built for RHEL-6.
Comment 12 IBM Bug Proxy 2010-04-27 16:51:18 EDT
------- Comment From cjashfor@us.ibm.com 2010-04-27 16:43 EDT-------
Successfully ran the ctests from PAPI-3.7.2 on a Power7 machine (alien4.ltc.austin.ibm.com) running RHEL 6 beta with the PAPI rpm installed.
Comment 14 Chris Ward 2010-07-12 08:42:29 EDT
Red Hat Enterprise Linux Beta 2 is now available and should resolve
the problem described in this bug report. One or more confirmation reports have already been received confirming this. This report is therefore being closed with a resolution of CURRENTRELEASE. You may reopen this bug report if the solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.