Bug 463391 - PS2 mouse on PS2-USB converter stopped working after upgrade
Summary: PS2 mouse on PS2-USB converter stopped working after upgrade
Keywords:
Status: CLOSED DUPLICATE of bug 456936
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Peter Hutterer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-09-23 04:10 UTC by Tim Taiwanese Liim
Modified: 2008-09-26 05:07 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-09-26 05:07:39 UTC
Type: ---


Attachments (Terms of Use)
dmesg as requested in Comment #1. (31.45 KB, text/plain)
2008-09-23 05:07 UTC, Tim Taiwanese Liim
no flags Details
yum update rpms; one of them caused the mouse to stop. (4.19 KB, text/plain)
2008-09-23 14:38 UTC, Tim Taiwanese Liim
no flags Details

Description Tim Taiwanese Liim 2008-09-23 04:10:41 UTC
Description of problem:

    I have a PS2 mouse that is connected via a PS2-USB converter.  
    It used to work fine, but stopped working after
      1. upgrade (yum update) to latest kernel (or whatever package);
      2. and a reboot.
    After the reboot, at the X window login, the kernel no longer
    recognize the mouse: move, click, no response.  Login to KDE,
    same, no response to mouse movement/clicks.

    At first I thought it's the mouse problem.  But booting with F7
    Live CD proved that the mouse is working fine.  Also to prove
    it's not my illusion, I have another F9 that worked fine with
    said mouse before upgrade, but stopped working after upgrade and
    reboot.

    It's quite possible that kernel is not the one to blame, but since
      1. /var/log/messages says kernel detected the mouse when 
         inserted;
      2. I don't know which module to assign this bug to;
    I picked kernel first.  
    Please reassign as you see fit.


Version-Release number of selected component (if applicable):
    kernel-2.6.26.3-29.fc9.i686

How reproducible:
    always

Steps to Reproduce:
    1. 'yum update' to upgrade to latest F9 as of 9/22/08.
    2. reboot.
  
Actual results:
    Mouse no longer working (no response to movement/clicks)
    at login window.

Expected results:
    Said mouse should be working (able to move mouse pointer),
    as it used to before the upgrade.

Additional info:

Comment 1 Pete Zaitcev 2008-09-23 04:28:16 UTC
May I get the output of dmesg(8) attached? I mean saving it to file
with "dmesg >/tmp/dmesg.dmesg", then attaching it as text/plain file.

Comment 2 Tim Taiwanese Liim 2008-09-23 05:07:34 UTC
Created attachment 317431 [details]
dmesg as requested in Comment #1.

Thanks for fast response.  Please see attached dmesg file.
BTW, I booted into an earlier kernel (2.6.25.14-108.fc9.i686) 
this time, still see the same no-response issue.

Comment 3 Tim Taiwanese Liim 2008-09-23 05:14:22 UTC
BTW, this seems to be the USB device I have:
    Bus 001 Device 005: ID 13ba:0017
I remove/insert the USB converter, and use 'lsusb' to 
see the difference, which is the above entry.

Since this issue was also seen in 2.6.25.14-108.fc9.i686, which
worked fine before reboot, my guess is, kernel is not guilty.
But I don't know what module it should go.

Comment 4 Pete Zaitcev 2008-09-23 05:26:01 UTC
Indeed dmesg looks like the kernel recognizes the keyboard and mouse:

input,hidraw0: USB HID v1.10 Keyboard [Generic USB K/B] on usb-0000:00:1d.7-3.4
input,hidraw1: USB HID v1.10 Mouse [Generic USB K/B] on usb-0000:00:1d.7-3.4

I expected to see some error.

Comment 5 Tim Taiwanese Liim 2008-09-23 14:38:37 UTC
Created attachment 317482 [details]
yum update rpms; one of them caused the mouse to stop.

I agree with your approach: do the basic check first.  

After kernel detecting the device, which module should pick up?

Attched please see a list of rpm updates; one of the updates caused
the problem (mouse was working before update, stopped after
update).  Some of are x11 related
    xorg-x11-drv-evdev-2.0.4-1.fc9.i386
    xorg-x11-drv-geode-2.10.1-1.fc9.i386
    xorg-x11-proto-devel-7.3-12.1.fc9.noarch
    xorg-x11-server-common-1.5.0-1.fc9.i386
    xorg-x11-server-Xorg-1.5.0-1.fc9.i386
    xorg-x11-xdm-1.1.6-3.fc9.i386
Maybe one of them caused the issue?

Comment 6 Tim Taiwanese Liim 2008-09-24 03:06:21 UTC
Found the culprit.  Update to
    xorg-x11-server-Xorg-1.5.0-1.fc9.i386
the mouse stopped working.  Downgrade to
    xorg-x11-server-Xorg-1.4.99.901-29.20080415.fc9.i386.rpm
mouse works again.  This is always reproducible.

Changed component to
    xorg-x11-server.



Updated bug report:

Description of problem:
    Same as in Comment #0.

Version-Release number of selected component (if applicable):
    xorg-x11-server-Xorg-1.5.0-1.fc9.i386

How reproducible:
    always

Steps to Reproduce:
    1. 'yum update' to xorg-x11-server-Xorg-1.5.0-1.fc9.i386
    2. reboot.
    3. move/click USB mouse.

Actual results:
    Mouse no longer working (no response to movement/clicks)
    at login window.

Expected results:
    Said mouse should be working (able to move mouse pointer),
    as it used to before the upgrade.

Additional info:
    workaround: (to others who ran into the same issue)
    before a fix is available, one can downgrade to an earlier 
    version, eg.
        i=xorg-x11-server-Xorg-1.4.99.901-29.20080415.fc9.i386.rpm
        rpm -U --oldpackage $i

Comment 7 Tim Taiwanese Liim 2008-09-25 01:34:55 UTC
Please reassign, now that we know the offending module
is xorg-x11-server-Xorg-1.5.0-1.fc9.i386.

Comment 8 Peter Hutterer 2008-09-26 04:45:24 UTC
Tim, can you cross-check with Bug 456936 please.
This issue should be fixed with xorg-x11-server-Xorg-1.5.0-2.fc9

Comment 9 Tim Taiwanese Liim 2008-09-26 05:07:39 UTC
Thanks, Peter.  That worked fine for me.  Indeed my PS2->USB converter
has both keyboard and mouse on it, thus fits description of bug 456936.
I'll mark this bug as duplicate.

*** This bug has been marked as a duplicate of bug 456936 ***


Note You need to log in before you can comment on or make changes to this bug.