Bug 463472 - NFS installation method refers to incorrect repository
NFS installation method refers to incorrect repository
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
NEEDSRETESTING
:
: 467041 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-23 12:18 EDT by Kazunori Asayama
Modified: 2013-01-09 23:48 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-28 09:55:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (11.27 KB, text/plain)
2008-09-23 15:24 EDT, Kazunori Asayama
no flags Details
output of 'mount' command (960 bytes, text/plain)
2008-09-24 10:52 EDT, Kazunori Asayama
no flags Details
File list of /mnt/stage2 (48 bytes, text/plain)
2008-09-24 10:55 EDT, Kazunori Asayama
no flags Details
File list of /mnt/source (504 bytes, text/plain)
2008-09-24 10:57 EDT, Kazunori Asayama
no flags Details
output of 'mount' command (713 bytes, text/plain)
2008-09-24 11:38 EDT, Kazunori Asayama
no flags Details
Screenshot of Exception report generated (104.35 KB, image/png)
2008-10-15 13:25 EDT, IBM Bug Proxy
no flags Details
Screenshot of error message (114.12 KB, image/png)
2008-10-15 13:25 EDT, IBM Bug Proxy
no flags Details
anaconda exception report generated during above error (57.23 KB, text/plain)
2008-10-15 13:25 EDT, IBM Bug Proxy
no flags Details
Screenshot of edit repository if we choose edit option in attachment (id=39682) (119.17 KB, image/png)
2008-10-15 13:25 EDT, IBM Bug Proxy
no flags Details

  None (edit)
Description Kazunori Asayama 2008-09-23 12:18:09 EDT
Description of problem:

It looks like NFS installation method tries to refer to the repository in the Internet regardless of specified NFS directory. So if no access to the Internate is available, the installation fails. The URL installation method works well.

Version-Release number of selected component (if applicable):

anaconda-11.4.1.39-1
boot.iso 2008.09.23 UTC

How reproducible:

Every time.

Steps to Reproduce:
1. Insert the boot disc (boot.iso) to the target machine.
2. Start installer with the option "askmethod".
3. Select 'NFS directory' installation method.
4. Configure network and fill the 'NFS directory' field.
5. Proceed installation with default installation options.

Actual results:

Just after the boot loader page, the installer fails with an error below:

---
Unable to read package metadata. This may be due to a missing repodata directory. Please ensure that your install tree has been correctly generated.

Cannot retrieve repository metadata (repomd.xml) for repository: rawhide. Please verify its path and try again
---

The tty1 displays an error message below:

---
Could not retrieve mirrorlist hettp://mirrors.fedoraproject.org/mirrorlist?repo=rawhide&arch=i386 error was
[Error 4] IOError: <urlopen error (-2, 'Name or service not known'))>
---

Expected results:

The NFS installation refers to the repository on the NFS directory.

Additional info:

As I mentioned above, if I use 'URL' installation method with the same repository as 'NFS directory' method, it works.
Comment 1 Chris Lumens 2008-09-23 13:04:14 EDT
Please attach /tmp/anaconda.log to this bug report.  Thanks.
Comment 2 Kazunori Asayama 2008-09-23 15:24:00 EDT
Created attachment 317515 [details]
anaconda.log
Comment 3 Kazunori Asayama 2008-09-24 10:52:22 EDT
Created attachment 317599 [details]
output of 'mount' command

Here is output of 'mount' command on the tty2's shell.

It looks like the NFS directory is successfully mounted at /mnt/stage2 and /mnt/source.
Comment 4 Kazunori Asayama 2008-09-24 10:55:22 EDT
Created attachment 317600 [details]
File list of /mnt/stage2
Comment 5 Kazunori Asayama 2008-09-24 10:57:50 EDT
Created attachment 317601 [details]
File list of /mnt/source
Comment 6 Kazunori Asayama 2008-09-24 11:38:53 EDT
Created attachment 317602 [details]
output of 'mount' command

(In reply to comment #3)
> It looks like the NFS directory is successfully mounted at /mnt/stage2 and
> /mnt/source.

Oops. That was my mistake. The previous mount's output was generated after I tried 'Edit Repository' dialog.

Attached is a correct output of 'mount' command just after the repository error.
Comment 7 Kazunori Asayama 2008-09-24 14:14:11 EDT
If I use 'method=nfs:***' option instead of 'askmethod', the NFS installation method works. So this problem seems to be a bug of 'askmethod' option.
Comment 8 Chris Lumens 2008-09-24 16:42:52 EDT
Yep, that's in line with what I was seeing.  I know what's going on here but I'm not going to be able to do anything about it until after the beta.  At least for now you have a known workaround.
Comment 9 Chris Lumens 2008-10-01 15:46:38 EDT
Okay, this should be fixed in the next build of anaconda.  Thanks for the report.
Comment 10 Chris Lumens 2008-10-15 13:12:30 EDT
*** Bug 467041 has been marked as a duplicate of this bug. ***
Comment 11 IBM Bug Proxy 2008-10-15 13:24:54 EDT
=Comment: #0=================================================
Pavan Naregundi <pavan.naregundi@in.ibm.com> -
During network installation of f10 beta, after partitioning of disk and formating error message is
displayed as shown below

=======================================================

????????????????????????????????????????????????????????????????????????????????? Error ????????????????????????????????????????????????????????????????????????????????????
???                                                            ???
??? Unable to read package metadata. This may be due to a      ???
??? missing repodata directory.  Please ensure that your       ???
??? install tree has been correctly generated.                 ???
???                                                            ???
??? Cannot retrieve repository metadata (repomd.xml) for       ???
??? repository: rawhide. Please verify its path and try again  ???
???                                                            ???
???    ??????????????????????????????????????????????????????        ????????????????????????        ???????????????????????????     ???
???    ??? Exit installer ???        ??? Edit ???        ??? Retry ???     ???
???    ??????????????????????????????????????????????????????        ????????????????????????        ???????????????????????????     ???
???                                                            ???
nnection ???                                                            ???
??????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????

<Tab>/<Alt-Tab> between elements   |  <Space> selects   |  <F12> next screen
=========================================================

I tried editing the path to my NFS repository path, with no use. I could see repodata directory in
NFS path and repomd.xml inside repodata.

Installation through hard disk image repository path also resulted in similar error.

Machine type: p550
CPU type: power5
=Comment: #1=================================================
Pavan Naregundi <pavan.naregundi@in.ibm.com> -

anaconda exception report generated during above error

=Comment: #3=================================================
Pavan Naregundi <pavan.naregundi@in.ibm.com> -
(In reply to comment #2)
> Did you try a DVD based installation?
>
Both DVD and CD based installation was producing same error.

=Comment: #8=================================================
Jochen Roth <jroth@linux.vnet.ibm.com> -
(In reply to comment #7)
> There was no checkbox option for select/unselect rawhide repository. But error
> was checking for presence of  repository named "Fedora - Rawhide Developmental
> packages for the next Fedora release" with source
> URL(http://mirrors.fedoraproject.org/mirrorlist?repo=rawhide&arch=ppc) and
> mirrorservice.com is not reachable from machine.

OK, do you think that you have / had the same problem as I had?
https://bugzilla.linux.ibm.com/show_bug.cgi?id=48635

You should really try to install with VNC to see this option (see screenshot in bug #48635) or try
to install without a firewall in between.
=Comment: #9=================================================
Pavan Naregundi <pavan.naregundi@in.ibm.com> -

Screenshot of error message

One can see here that error message occurs just after partition. Only options available are exit
installer and edit the repo.
=Comment: #10=================================================
Pavan Naregundi <pavan.naregundi@in.ibm.com> -

Screenshot of edit repository if we choose edit option in attachment (id=39682)

=Comment: #11=================================================
Pavan Naregundi <pavan.naregundi@in.ibm.com> -

Screenshot of Exception report generated

*** This bug has been marked as a duplicate of 463472 ***
Comment 12 IBM Bug Proxy 2008-10-15 13:25:04 EDT
Created attachment 320459 [details]
Screenshot of Exception report generated
Comment 13 IBM Bug Proxy 2008-10-15 13:25:13 EDT
Created attachment 320460 [details]
Screenshot of error message
Comment 14 IBM Bug Proxy 2008-10-15 13:25:22 EDT
Created attachment 320461 [details]
anaconda exception report generated during above error
Comment 15 IBM Bug Proxy 2008-10-15 13:25:33 EDT
Created attachment 320462 [details]
Screenshot of edit repository if we choose edit option in attachment (id=39682)
Comment 16 IBM Bug Proxy 2008-10-24 07:32:08 EDT
Redhat, Any update on this bug? Thanks!
Comment 17 Chris Lumens 2008-10-24 10:09:49 EDT
This should be fixed in 11.4.1.41-1 or later, which is the version after the one you tried to install with.  The NEEDSRETESTING keyword combined with a status of ON_QA means we believe it is fixed, but would appreciate testing and verifying of that.
Comment 18 Kazunori Asayama 2008-10-27 21:50:43 EDT
Yes, indeed this problem has been fixed in the latest rawhide (11.4.1.51-1).
Comment 19 IBM Bug Proxy 2008-11-07 07:21:37 EST
I have tested this over F10 Preview and you can close this bug.


Redhat, We are closing this bug now. Thanks!

Note You need to log in before you can comment on or make changes to this bug.