Bug 463484 - Activate networking from stage#2 fails
Activate networking from stage#2 fails
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
: 464015 (view as bug list)
Depends On:
Blocks: F10Preview
  Show dependency treegraph
 
Reported: 2008-09-23 13:34 EDT by James Laska
Modified: 2013-09-02 02:27 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-25 11:57:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anacdump.txt (80.48 KB, text/plain)
2008-09-23 13:34 EDT, James Laska
no flags Details

  None (edit)
Description James Laska 2008-09-23 13:34:35 EDT
Created attachment 317499 [details]
anacdump.txt

Booted the boot.iso, attempted to activate networking at the repo selection screen. 

See attached anacdump.txt
Comment 1 Will Woods 2008-09-23 19:13:12 EDT
For the record, here's the top of the trace: 

anaconda 11.4.1.38 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/iw/netconfig_dialog.py", line 191, in _ok
    netdev.bringDeviceUp()
  File "/usr/lib/anaconda/iw/netconfig_dialog.py", line 144, in run
    if self._ok():
  File "/usr/lib/anaconda/gui.py", line 1160, in enableNetwork
    ret = net.run()
  File "/usr/lib/anaconda/yuminstall.py", line 1066, in __withFuncDo
    if anaconda.intf.enableNetwork(anaconda):
  File "/usr/lib/anaconda/yuminstall.py", line 1031, in doSackSetup
    thisrepo=thisrepo, fatalerrors=fatalerrors, progress=True)
  File "/usr/lib/anaconda/yuminstall.py", line 988, in doBackendSetup
    self.doSackSetup(anaconda)
  File "/usr/lib/anaconda/backend.py", line 246, in doBackendSetup
    if anaconda.backend.doBackendSetup(anaconda) == DISPATCH_BACK:
  File "/usr/lib/anaconda/dispatch.py", line 204, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 127, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1349, in nextClicked
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib/anaconda/gui.py", line 1479, in keyRelease
    self.nextClicked()
AttributeError: NetworkDevice instance has no attribute 'bringDeviceUp'

Local variables in innermost frame:
val: eth0
netdev: DEVICE=eth0
BOOTPROTO=dhcp
HWADDR=00:17:08:2a:72:3d
ONBOOT=yes
Comment 2 Jesse Keating 2008-09-23 19:16:02 EDT
I don't seem to get a traceback on this, instead I just get a failure to
download the metadata.  No prompts to configure network.

Also, the anaconda version I'm testing is 11.4.1.39

Yours is anaconda 11.4.1.38.
Comment 3 David Cantrell 2008-09-24 22:32:18 EDT
Problem here was we needed to call res_init() in glibc to reinit the resolver for the new /etc/resolv.conf that NM wrote out.  This will be fixed in anaconda-11.4.1.40-1.
Comment 4 James Laska 2008-09-25 18:26:17 EDT
*** Bug 464015 has been marked as a duplicate of this bug. ***
Comment 5 Will Woods 2008-10-25 11:57:04 EDT
Tested with Snap3 i386 DVD - everything worked as expected.

Note You need to log in before you can comment on or make changes to this bug.