Bug 463527 - The system can't boot after text mode installation
The system can't boot after text mode installation
Status: CLOSED DUPLICATE of bug 458553
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-23 16:18 EDT by Kazunori Asayama
Modified: 2008-09-24 09:43 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-24 09:43:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kazunori Asayama 2008-09-23 16:18:34 EDT
Description of problem:

The system stalls while rebooting after text mode installation.

Version-Release number of selected component (if applicable):

anaconda-11.4.1.39-1
boot.iso 2008.09.23 UTC

How reproducible:

Every time.

Steps to Reproduce:
1. Do text mode installation.
2. Reboot.
  
Actual results:

The system stalls during reboot process after text mode installation. The progress bar seems to reach the right end of the screen, but no more progress.

Expected results:

Reboot correctly.

Additional info:

If I manually switch to run level 3 *after graphical mode installation* by editing /etc/inittab, the system can normally boot.
Comment 1 Chris Lumens 2008-09-23 16:22:43 EDT

*** This bug has been marked as a duplicate of bug 458553 ***
Comment 2 Kazunori Asayama 2008-09-23 16:36:22 EDT
I don't think this is the same as Bug 458553. The progress bar becomes entirely white and reach the right end of the screen. I tried this with the latest (2008.09.23) boot image (anaconda-11.4.1.39-1). Is this really the same as Bug 458553 ?
Comment 3 Chris Lumens 2008-09-23 16:38:31 EDT
Yes, yes it is.  The firstboot that fixes this bug is not in the latest Fedora tree.  You need firstboot-1.100-1.  If you hit escape or some other key when you've got the fully white progress bar, you should see the text firstboot interface.

*** This bug has been marked as a duplicate of bug 458553 ***
Comment 4 Kazunori Asayama 2008-09-23 16:48:10 EDT
No, I can't see firstboot UI, even if I hit escape or any other key...
Comment 5 Chris Lumens 2008-09-23 18:51:57 EDT
Please grab the latest firstboot packages for your architecture from http://koji.fedoraproject.org/koji/buildinfo?buildID=62883 and let me know if this solves the problem for you.  If so, this is definitely a duplicate of 458553.  If not, I'm going to need a lot more information in order to reproduce this problem.
Comment 6 Kazunori Asayama 2008-09-24 01:25:48 EDT
I found the system behaves as you are saying if I press any key *just* after the bar becomes white. OK, I'll try the new firstboot.
Comment 7 Kazunori Asayama 2008-09-24 01:38:06 EDT
It works with the latest firstboot! Thank you. So will the new firstboot be included in F10?
Comment 8 Chris Lumens 2008-09-24 09:43:37 EDT
Yes, definitely.  Probably not in the beta though.

*** This bug has been marked as a duplicate of bug 458553 ***

Note You need to log in before you can comment on or make changes to this bug.