Bug 463714 - alsa: usbaudio should not claim to have DB info when hw_dB_min == hw_dB_max
alsa: usbaudio should not claim to have DB info when hw_dB_min == hw_dB_max
Status: CLOSED DUPLICATE of bug 469416
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-24 03:51 EDT by Hans de Goede
Modified: 2009-03-28 10:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-28 10:19:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2008-09-24 03:51:51 EDT
Description of problem:
When plugging in my usb webcam with usbaudio mic, pulse aborts with the following message:
E: module-alsa-source.c: Assertion 'u->hw_dB_min < u->hw_dB_max' failed at
modules/module-alsa-source.c:1284, function module_alsa_source_LTX_pa__init().

I've filed a bug against pulse for this see bug 462247 and Lennart says its an alsa bug, as alsa in the case of invalid DB info simple should report no DB info instead of reporting invalid info. I agree with Lennart on this.
Comment 1 Bug Zapper 2008-11-25 22:12:09 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Chuck Ebbert 2009-03-28 10:19:34 EDT

*** This bug has been marked as a duplicate of bug 469416 ***

Note You need to log in before you can comment on or make changes to this bug.