Bug 462247 - support for ALSA drivers which lack dB info broken
support for ALSA drivers which lack dB info broken
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
: 465434 (view as bug list)
Depends On:
Blocks: F10Blocker/F10FinalBlocker
  Show dependency treegraph
 
Reported: 2008-09-14 15:13 EDT by Hans de Goede
Modified: 2008-10-06 13:34 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-06 13:34:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2008-09-14 15:13:20 EDT
Description of problem:
Login to gnome session, notice sound is not working, a ps reveales that pulse is not running, try starting pulse from a terminal, result:

[hans@localhost ~]$ pulseaudio 
<snip rt prio messages>
W: alsa-util.c: Device hw:1 doesn't support 44100 Hz, changed to 32000 Hz.
E: module-alsa-source.c: Assertion 'u->hw_dB_supported' failed at modules/module-alsa-source.c:742, function source_get_volume_cb(). Aborting.
Aborted
[hans@localhost ~]$

This goes away if I rmmod snd_bt87x, so appearantly pulseaudio does not like the capture capabilities offered by the bt87x video grab IC much. I can run any tests / diagnostics you want me to, just name it.


Version-Release number of selected component (if applicable):
pulseaudio-0.9.12-5.fc10.x86_64



How reproducible:
Always

Steps to Reproduce:
1. Take a PC with a bt87x card and snd_bt87x loaded
2. Start pulseaudio
  
Actual results:
aborts.

Expected results:
Runs as normal.
Comment 1 Hans de Goede 2008-09-14 16:53:30 EDT
Hmm,

I just managed to reproduce this (well almost, different but related abort) with another capture only device, a webcam with a microphone which shows up as an capture only usb audio device, this time the assert is:

E: module-alsa-source.c: Assertion 'u->hw_dB_min < u->hw_dB_max' failed at modules/module-alsa-source.c:1284, function module_alsa_source_LTX_pa__init(). Aborting.

pulseaudio crashing in these cases is not good, as that results to no sound. making this an F10Blocker.
Comment 2 Michael Schwendt 2008-09-15 08:48:31 EDT
> This goes away if I rmmod snd_bt87x

Confirmed here.
Comment 3 Lennart Poettering 2008-09-23 18:10:46 EDT
These are two different bugs. Please don't hijack bug reports.

The one about u->hw_dB_supported is an actual bug in PA. The other one is a bug in ALSA. ALSA hands us invalid data: it shouldn't claim it supports dB info for a card when the dB range is 0dB to 0dB.

Hans, please file a new bug against ALSA/kernel please.
Comment 4 Hans de Goede 2008-09-24 03:55:02 EDT
(In reply to comment #3)
> These are two different bugs. Please don't hijack bug reports.
> 
> The one about u->hw_dB_supported is an actual bug in PA. The other one is a bug
> in ALSA. ALSA hands us invalid data: it shouldn't claim it supports dB info for
> a card when the dB range is 0dB to 0dB.
> 
> Hans, please file a new bug against ALSA/kernel please.

Done against the kernel, bug 463714, I would like to request for the assert to be changed into a warning and to treat the invalid DB info as no DB info though, no idea when this will get fixed in the kernel and it would be nice to not have pa aborting in F-10.
Comment 5 Lennart Poettering 2008-09-30 22:12:35 EDT
Hmm, I am not so keen on taping over kernel bugs like this, but maybe i should indeed do this.

The issue about u->hw_dB_supported is now fixed upstream.
Comment 6 Lennart Poettering 2008-09-30 22:15:49 EDT
Ok, I changed upstream now to simply warn the user with such invalid dB data instead of hitting an assert.
Comment 7 Hans de Goede 2008-10-01 02:53:16 EDT
(In reply to comment #6)
> Ok, I changed upstream now to simply warn the user with such invalid dB data
> instead of hitting an assert.

Thanks,

I hope we will see a rawhide package with these 2 fixes in there soon? Having to rmmod the snd modules for the relevant devices each time I want sound is getting pretty old pretty quickly.
Comment 8 Lennart Poettering 2008-10-03 08:59:05 EDT
*** Bug 465434 has been marked as a duplicate of this bug. ***
Comment 9 Lennart Poettering 2008-10-06 13:34:59 EDT
Fixed in 0.9.13-1

Note You need to log in before you can comment on or make changes to this bug.