Bug 463777 - /sbin/weak-updates error: nm: 'a.out': No such file
/sbin/weak-updates error: nm: 'a.out': No such file
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: module-init-tools (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Jon Masters
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-24 12:59 EDT by Victor Gregorio
Modified: 2009-09-02 07:27 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 07:27:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Victor Gregorio 2008-09-24 12:59:36 EDT
Description of problem:

/sbin/weak-updates expects /lib/modules/$(uname -r)/extra to have *.ko files, triggering an error with /usr/bin/nm

Version-Release number of selected component (if applicable):

module-init-tools-3.3-0.pre3.1.37.el5

How reproducible:

Every time

Steps to Reproduce:

echo /path/to/kernel/module.ko | /sbin/weak-updates --add-module
  
Actual results:

nm: 'a.out': No such file

Expected results:

No error from nm, which assumes a.out when no argument is supplied.

Additional info:

If /lib/modules/$(uname -r)/extra is empty, /sbin/weak-modules still runs nm on nothing, triggering the 'a.out' : No such file error.

222         # Symbols that other add-on modules of the "old" kernel export
223         # (and that this module may require)
224         if [ ! -e "$tmpdir/extra-symvers-$module_krel" ]; then
225             if [ -e /lib/modules/$module_krel/extra ]; then
226                 find /lib/modules/$module_krel/extra -name '*.ko' \
227                 | xargs nm \
228                 | sed -nre 's:^[0]*([0-9a-f]{8}) A __crc_(.*):0x\1 \2:p'
229             fi > $tmpdir/extra-symvers-$module_krel
230         fi
Comment 2 Jon Masters 2009-05-11 16:20:36 EDT
*** Bug 468280 has been marked as a duplicate of this bug. ***
Comment 9 errata-xmlrpc 2009-09-02 07:27:59 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1362.html

Note You need to log in before you can comment on or make changes to this bug.