Bug 468280 - Missing package dependency
Missing package dependency
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: module-init-tools (Show other bugs)
5.2
All Linux
medium Severity low
: rc
: ---
Assigned To: Jon Masters
BaseOS QE
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-23 17:00 EDT by Sean E. Millichamp
Modified: 2010-04-30 16:28 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-12 17:23:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
CentOS 3205 None None None Never

  None (edit)
Description Sean E. Millichamp 2008-10-23 17:00:00 EDT
Description of problem:

/sbin/weak-modules calls "nm".

nm is provided by the binutils package, which is not a dependency of module-init-tools.  If binutils isn't installed then /sbin/weak-modules shows errors about not being able to run nm ('xargs: nm: No such file or directory')

Version-Release number of selected component (if applicable):

module-init-tools-3.3-0.pre3.1.37.el5

How reproducible:

Every time.

Additional info:

The addition of:
Requires (pre): binutils
in the specfile should fix it.
Comment 1 Juan Quintela 2009-04-13 08:50:01 EDT
Once there, weak-modules also calls mkinitrd, and it don't depend on it.

I was able to get a machine install without mkinitrd with this %packages section on the kickstart:

%packages
@base
@base-x
@core
@gnome-desktop
comps-extras
cracklib-dicts
gnome-mime-data
gnome-applets
autofs
rmt
tzdata
gcc
ncurses-devel
python-devel
rpm-build
strace
zlib-devel
-anacron
Comment 2 Jon Masters 2009-05-11 16:20:36 EDT

*** This bug has been marked as a duplicate of bug 463777 ***
Comment 3 Sean E. Millichamp 2009-05-11 16:36:08 EDT
How is this a duplicate of #463777 ?

That bug is about calling nm without passing any parameters.  This bug is about RPM package dependencies.  They are both regarding nm, but that is as far as I see the similarity go.
Comment 5 Jon Masters 2009-05-12 17:23:38 EDT
This actually got fixed as part of 463777 is what I mean :)

Note You need to log in before you can comment on or make changes to this bug.