Bug 463892 - [te_IN] rendering failed and cursoring failed in konqueror for some GSUB conjunction
[te_IN] rendering failed and cursoring failed in konqueror for some GSUB conj...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: pango (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Behdad Esfahbod
desktop-bugs@redhat.com
: Desktop
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-25 02:54 EDT by Vivian Bian
Modified: 2008-09-25 03:25 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-25 03:25:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This is the picture about the testing result in konqueror (53.07 KB, image/png)
2008-09-25 02:59 EDT, Vivian Bian
no flags Details

  None (edit)
Description Vivian Bian 2008-09-25 02:54:25 EDT
Description of problem:
When visit the URL    
http://focus.bne.redhat.com/I18N/IndicTC/lang/te_IN/font/IndicFontTestCaseGSUB-Telugu.html
via the konqueror browser,and test the #285 font there were the cursoring error
for that I must knock three times the left /right cursor to make the cursor
move to the left /right with the current font,and when use    
the BackSpace key to delete the word,it could not match the number of the
unicode.More over,we must knock the Delete key three times to delete the word.

And the char is not displayed correctly in the konqueror browser

The Unicode of the word is U+0C37 U+0C4D U+0C1F U+0C4D U+0C30 U+0C40 

Version-Release number of selected component (if applicable):
fonts-telugu-2.3.1-1.el5
konqueror browser in rhel 5.2
pango-1.14.9-3.el5


How reproducible:
Always

Steps to Reproduce:
1.visit the website given above and turn to the te_IN GSUB #285,and just knock 
the Backspace key according to the unicode (knock the Backspace for times the 
same as the number of the unicode of the word) 
2.Knock the Delete key on the word just for once
3.Knock the left/right key on the word just for once
4.just make a comparison between the image and the char in the textbox

Actual results:
1.The cursor can be positioned in the middle of the char when click the
left/right key.
2.When Click the Backspcae key to remove the char,we can remove it via clicking
the Backspace four times,but actually we should click it six times.
3.When click the Delete key to delete the char,we have to delete it via
clicking the Delete key three times.
4.The char could not be displayed the same as the image

Expected results:

All the cursors can work as the requirement given below:
1.Delete:it should delete the entire composed char at a time
2.Backspace:need to several times to remove the char,it depends on each char
unicode
3.cursor(left,right):must not be positioned at the middle of the char anyhow,so
cursor just for one time
4.The char could not be displayed the same as the image

Additional info:
Comment 1 Vivian Bian 2008-09-25 02:59:33 EDT
Created attachment 317657 [details]
This is the picture about the testing result in konqueror
Comment 2 Rahul Bhalerao 2008-09-25 03:25:51 EDT
The reason why this is not a bug is given at
https://bugzilla.redhat.com/show_bug.cgi?id=463411#c7

Note You need to log in before you can comment on or make changes to this bug.