Bug 464389 - double click node on the navigator quickly will make the page blank
double click node on the navigator quickly will make the page blank
Status: CLOSED WONTFIX
Product: Virtualization Tools
Classification: Community
Component: ovirt-server-suite (Show other bugs)
unspecified
All Linux
medium Severity low
: ---
: ---
Assigned To: Jason Guiditta
:
: 497829 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-27 23:23 EDT by aning
Modified: 2011-06-22 10:59 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-22 10:59:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
blank page after double click a node on the navigator quickly (55.31 KB, image/png)
2008-09-27 23:23 EDT, aning
no flags Details

  None (edit)
Description aning 2008-09-27 23:23:52 EDT
Created attachment 317879 [details]
blank page after double click a node on the navigator quickly

Description of problem:
double click node on the navigator quickly will make the page blank

Version-Release number of selected component (if applicable):
ovirt-0.93

How reproducible:
almost always

Steps to Reproduce:
1.Open the ovirt Administration User Interface
2.Double click a node(eg hardware pool or virtual machine pool) on the navigator quickly
  
Actual results:
the page become blank

Expected results:
give a message or stay the same page or do anything else but the blank page

Additional info:
Comment 1 Susan Burgess 2008-10-06 00:49:01 EDT
not a doc bug.
Comment 2 Hugh Brock 2008-10-17 14:11:55 EDT
Confirmed, all you have to do is click like crazy on the tree and the whole screen blanks. This is also true with 0.94.
Comment 3 Jason Guiditta 2008-10-17 17:41:15 EDT
Ok, I have found what is causing the issue, but don't yet have a solution.  Basically, when you 'click like crazy', the nav tries to load the content area (tabs + area beneath).  Once this loads, the tab component selects the first tab, which issues another request to get the content for the selected tab.  Since the responses are processed as soon as they are received, if the tab content comes back and the tree is in the middle of replacing content, there may be no target html to insert the tab response into.  I verified this by disabling the tabs and clicking like a madman.  Page never goes blank.  

I think the solution is to queue the requests, which I tried out, and it works nicely (sadly, yes, another plugin).  However, I have not been able to figure out how to make the tab component use the queue.  I have a question out to the developers of that component on whether it is possible.  Depending on their response, I may need to add the functionality myself (and try to get it upstreamed).
Comment 4 Jason Guiditta 2009-05-26 10:40:36 EDT
*** Bug 497829 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.