Bug 464433 - Autoupdates failing
Autoupdates failing
Status: CLOSED DUPLICATE of bug 428323
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum-rhn-plugin (Show other bugs)
5.4
All Linux
medium Severity high
: rc
: ---
Assigned To: John Matthews
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-28 17:14 EDT by D Campbell
Modified: 2008-10-15 18:36 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-15 18:36:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description D Campbell 2008-09-28 17:14:02 EDT
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.0.12) Gecko/20070718 Red Hat/1.5.0.12-3.el5 Firefox/1.5.0.12

Component: Software Updater
Summary: TBd05087db rhnplugin.py:298:_noExceptionWrappingGet:UnboundLocalError: local variable 'result' referenced before assignment

Traceback (most recent call last):
  File "/usr/sbin/pup", line 438, in _apply
    self.applyChanges(self.mainwin)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 557, in applyChanges
    self.checkDeps(mainwin)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 322, in checkDeps
    self.populateTs(keepold=0)
  File "/usr/lib/python2.4/site-packages/yum/depsolve.py", line 153, in populateTs
    self.downloadHeader(txmbr.po)
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 760, in downloadHeader
    cache=repo.http_caching != 'none',
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 461, in getHeader
    cache=cache,
  File "/usr/lib/yum-plugins/rhnplugin.py", line 209, in _getFile
    start, end, copy_local, checkfunc, text, reget, cache)
  File "/usr/lib/yum-plugins/rhnplugin.py", line 298, in _noExceptionWrappingGet
    return result
UnboundLocalError: local variable 'result' referenced before assignment

Local variables in innermost frame:
remote: https://xmlrpc.rhn.redhat.com/XMLRPC/GET-REQ/rhel-x86_64-server-5/getPackage/glibc-2.5-24.i686.rpm
start: 440
url: None
text: None
self: rhel-x86_64-server-5
cache: True
reget: None
server: https://xmlrpc.rhn.redhat.com/XMLRPC/GET-REQ/rhel-x86_64-server-5
relative: getPackage/glibc-2.5-24.i686.rpm
headers: (('X-RHN-Auth-Expire-Offset', '3600.0'), ('X-RHN-Auth-User-Id', ''), ('X-RHN-Auth', 'nn5Cn3TduIBLukCj6G3XBQ=='), ('X-RHN-Auth-Server-Time', '1222632024.57'), ('X-RHN-Server-Id', 1013688054))
checkfunc: (<bound method PackageUpdater.verifyHeader of <__main__.PackageUpdater object at 0x13bdf690>>, (<yum.sqlitesack.YumAvailablePackageSqlite instance at 0x17f86560>, 1), {})
copy_local: 1
end: 149552
local: //var/cache/yum/rhel-x86_64-server-5/headers/glibc-2.5-24.i686.hdr


Reproducible: Always

Steps to Reproduce:
1.Select to install available updates 
2.
3.
Actual Results:  
Nothing is seen until the error window appears.

Expected Results:  
Updates install

first time this has been tried since new machine build.
Comment 1 banowetz 2008-10-15 18:02:28 EDT
I have the same error, also with a new machine build!
Comment 2 John Matthews 2008-10-15 18:36:15 EDT
Seeing this error:
UnboundLocalError: local variable 'result' referenced before assignment

Typically happens when a network error occured, the "result referenced before assignment" is hiding the real problem.

*** This bug has been marked as a duplicate of bug 428323 ***

Note You need to log in before you can comment on or make changes to this bug.