Bug 464622 - existing distribution lists not visible in upgraded kaddressbook
existing distribution lists not visible in upgraded kaddressbook
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kdepim (Show other bugs)
8
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kevin Kofler
Fedora Extras Quality Assurance
:
: 465241 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-29 14:48 EDT by Bob Tennent
Modified: 2008-10-14 18:37 EDT (History)
7 users (show)

See Also:
Fixed In Version: 3.5.10-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-01 02:38:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 170259 None None None Never

  None (edit)
Description Bob Tennent 2008-09-29 14:48:15 EDT
Description of problem: After upgrading to kdepim-3.5.10-1, existing distribution lists are not visible.


Version-Release number of selected component (if applicable): kdepim-3.5.10-1


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info: It seems (kdepim-users mail list) that the developer changed the format and forgot that users might want to keep their 1000-name distribution lists alive (!).   He has apparently produced something called kabcdistlistupdater to address this issue. Please incorporate into an updated package ASAP. 

http://lists.kde.org/?t=122025627500001&r=1&w=2
Comment 1 Rex Dieter 2008-09-29 14:59:05 EDT
ouchie.  thanks for the pointer.
Comment 2 Kevin Kofler 2008-09-29 15:08:50 EDT
Grrr, why did nobody tell us? This has been known since at least September 4! We would have fixed this in our packages long ago, when they were still in testing, if somebody had bothered notifying us.

This shows that:
* KDE developers don't notify packagers of important issues. That's bad.
* Nobody uses Fedora updates-testing at all. In fact, I got zero feedback on the KDE 3.5.10 updates. And it's not just F8, because kdepim 3.5.10 is also part of the F9 updates. That's even worse.
Comment 3 Kevin Kofler 2008-09-29 15:18:56 EDT
And is this even a new issue in 3.5.10? The upstream commit message at http://websvn.kde.org/?view=rev&revision=856958 claims the new format was already used in 3.5.9.

The mechanism used by upstream to invoke the converter is also really broken, they invoke it on KDE startup, which makes no sense at all, it should be invoked when something actually accessing the distribution list is invoked! The way they do it now, the upgrade may happen much too late (because KDE isn't necessarily restarted immediately after the package update) and it is also done before being actually needed. :-(

For config files, there's kconf_update which solves this problem properly, but these are application data (in the apps directory), not config files (in the config directory), so kconf_update can't be used.

The best we can do here is apply the patch from upstream and issue an update for it. My feeling is that this won't completely solve this issue, but I don't have a better solution.
Comment 4 Kevin Kofler 2008-09-29 15:21:00 EDT
Note that KDE 4 also uses the new format and the updater is missing there. We should probably port it for Rawhide (which has kdepim 4.1).
Comment 5 Kevin Kofler 2008-09-29 15:40:45 EDT
Another big issue with doing things the way upstream does it is that it will only fix things for KDE users. What about people using kdepim in GNOME? They'll have to run the tool by hand. :-(
Comment 6 Bob Tennent 2008-09-29 15:47:45 EDT
"Fixed in Version 3.5.10-2"  Where do I find that?  It's not in updates-testing (yet).
Comment 7 Kevin Kofler 2008-09-29 16:23:57 EDT
It's still building. That's why this bug is just MODIFIED, not CLOSED. :-) It'll get closed once the update is actually pushed to stable (and ON_QA means the update is in testing).

It'll probably take a while for the update to actually get pushed anywhere (pushes aren't instant, there are grouped update pushes about once or twice a week), but I'll post links to download the package directly from our build system (Koji) as soon as the builds completed.
Comment 9 Bob Tennent 2008-09-29 17:05:25 EDT
F8 i386 build works for me.  (Had to invoke kabcdistlistupdater explicitly because
I upgraded remotely.)  Thanks.  

BTW, you might be amused at the reaction to my blast at

http://lists.kde.org/?t=122025627500001&r=1&w=2

"The problem has been 
fixed promptly and the fix is readily available for your distributor to 
pick it up"

There's definitely been a breakdown in communication.
Comment 10 Fedora Update System 2008-09-29 18:18:10 EDT
kdepim-3.5.10-2.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/kdepim-3.5.10-2.fc9
Comment 11 Fedora Update System 2008-09-29 18:18:37 EDT
kdepim-3.5.10-2.fc8 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/kdepim-3.5.10-2.fc8
Comment 12 Fedora Update System 2008-10-01 02:33:40 EDT
kdepim-3.5.10-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2008-10-01 02:38:39 EDT
kdepim-3.5.10-2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Kevin Kofler 2008-10-02 07:59:41 EDT
*** Bug 465241 has been marked as a duplicate of this bug. ***
Comment 15 Kevin Kofler 2008-10-14 18:37:24 EDT
kdepim-4.1.2-3.fc10 is currently building for Rawhide with a KDE 4 port of this converter. (kdepim 4.1 also uses the new format, so this should help people migrating from old KDE 3 versions of kdepim).

Note You need to log in before you can comment on or make changes to this bug.