Bug 46475 - .xsession-errors: unbound variables
.xsession-errors: unbound variables
Status: CLOSED DUPLICATE of bug 7860
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-28 20:58 EDT by molinero
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-28 07:34:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description molinero 2001-06-28 20:58:58 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [es] (X11; U; Linux 2.4.3-12 i686)

Description of problem:
I could not log in using gdm. The screen blinked and I got back to the gdm
greeting. There was not a problem with the authentication. I declared some
variables and now it works again.

I believe this has to do with either having LC_* and LANG variables not
being C/English, or some shell (sh) environment variable that affects
comparisons of the sort [ -z "$VAR" ]

I needed to define the variablesXKB_IN_USE, XIM, XIM_PROGRAM, XMODIFIERS,
so that /etc/X11/xdm/Xsession does not complain in the [ -z "$VAR" ]
comparisons.

I defined the variables under /etc/sysconfig/i18n as empty (VAR="") and it
worked. 

My environment vars are:
'!'=6939
'#'=1
'$'=6916
'*'=(rmstar)
-=J960hiR5Qs
0=zsh
'?'=0
@=(rmstar)
ARCH=i686-unknown-linux
ARGC=1
BAUD=38400
CDPATH=''
CLASSPATH=/afs/ir/class/cs444i/ninja:/afs/ir/class/cs444i/ninja/support/activation.jar:/afs/ir/class/cs444i/ninja/support/mail.jar:/afs/ir/class/cs444i/ninja/support/swing.jar:.:/opt/java/lib:/usr/lib/jdk-1.1.7/:/usr/pubsw/apps/jdk/lib/:/home/molinero/swing-1.0.2/swing.jar
COLORTERM=gnome-terminal
COLUMNS=110
CURRENT_SHELL=/bin/zsh
CVSEDITOR=xemacs
CVSROOT=/hpn/home/tinytera/CVS
DEF_PATH='/usr/local/bin /etc/leland/bin /usr/kerberos/bin
/hpn/home/molinero/bin/scripts /hpn/home/molinero/bin/i686-unknown-linux .
/usr/bin/X11 /usr/X11R6/bin /usr/etc /etc /usr/games /bin /usr/bin
/usr/local/bin /usr/pubsw/bin /usr/pubsw/X/bin /usr/newsw/bin
/usr/X11R6/bin /usr/pubsw/bin /usr/pubsw/X/bin /usr/hpnbin/office52
/hpn/home/molinero/bin /etc/leland/bin /usr/bin /bin /usr/local/bin
/usr/ucb /usr/lang /usr/bin/X11 /usr/local/bin /etc/leland/bin
/usr/kerberos/bin /hpn/home/molinero/bin/scripts
/hpn/home/molinero/bin/i686-unknown-linux . /usr/bin/X11 /usr/X11R6/bin
/usr/etc /etc /usr/games /bin /usr/bin /usr/local/bin /usr/pubsw/bin
/usr/pubsw/X/bin /usr/newsw/bin /usr/X11R6/bin /usr/pubsw/bin
/usr/pubsw/X/bin /usr/hpnbin/office52 /hpn/home/molinero
DISPLAY=:0
EDITOR=emacs
EGID=100
ERRNO=2
EUID=20246
FCEDIT=vi
FIGNORE='~:#:.o'
FM_FLS_HOST=powderkeg.stanford.edu
FPATH=/usr/local/lib/zsh/func
GID=100
GZIP=-9
HELPDIR=/usr/local/lib/zsh/help
HISTCHARS='!^#'
HISTFILE=/hpn/home/molinero/.zsh_history
HISTSIZE=200
HOME=/hpn/home/molinero
HOST=manzanares.Stanford.EDU
HOSTNAME=manzanares.Stanford.EDU
HOSTTYPE=i386
IFS='   
^@'
INPUTRC=/etc/inputrc
JAVA_HOME=/usr/lib/jdk-1.1.7/
KAFFEHOME=/usr/local/share/kaffe
KDEDIR=/usr
KEYTIMEOUT=40
LANG=es_ES
LC_ALL=es_ES
LC_CTYPE=ISO-8859-1
LD_PRELOAD=/lib/libsafe.so.1.3
LESS=-e
LESSCHARSET=latin1
LESSOPEN='|/usr/bin/lesspipe.sh %s'
LINENO=60
LINES=28
LISTMAX=100
LITHISTSIZE=200
LOGCHECK=60
LOGNAME=molinero
LS_COLORS='no=00:fi=00:di=01;34:ln=01;36:pi=40;33:so=01;35:bd=40;33;01:cd=40;33;01:or=01;05;37;41:mi=01;05;37;41:ex=01;32:*.cmd=01;32:*.exe=01;32:*.com=01;32:*.btm=01;32:*.bat=01;32:*.sh=01;32:*.csh=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.gz=01;31:*.bz2=01;31:*.bz=01;31:*.tz=01;31:*.rpm=01;31:*.cpio=01;31:*.jpg=01;35:*.gif=01;35:*.bmp=01;35:*.xbm=01;35:*.xpm=01;35:*.png=01;35:*.tif=01;35:'
MACHTYPE=i386
MAIL=/var/spool/mail/molinero
MAILCHECK=60
MAILPATH=''
MANPATH=/usr/share/man:/usr/man:/man:/usr/X11R6/man:/usr/lib/perl5/man:/usr/kerberos/man:/usr/local/man:/usr/local/X11R5/man:/usr/local/X11/man:/hpn/home/molinero/bin/man:/usr/man:/man:/usr/local/man:/usr/pubsw/man:/usr/pubsw/man:/usr/pubsw/X/man:/usr/afsws/man
MATLAB=/usr/local/matlab5.2
MOZILLA_HOME=/usr/local/bin/netscape
NNTPSERVER=nntp
NULLCMD=cat
OLDPWD=/hpn/home/molinero/.inicial
OPTARG=''
OPTIND=1
OSTYPE=linux-gnu
PAGER=less
PATH=/hpn/home/molinero/bin/scripts:/hpn/home/molinero/bin/i686-unknown-linux:.:/usr/bin/X11:/usr/X11R6/bin:/usr/etc:/etc:/usr/games:/bin:/usr/bin:/usr/local/bin:/hpn/home/molinero/bin:/etc/leland/bin:/usr/bin:/bin:/usr/local/bin:/usr/ucb:/usr/lang:/usr/bin/X11:/hpn/home/molinero/bin/scripts:/hpn/home/molinero/bin/i686-unknown-linux:.:/usr/bin/X11:/usr/X11R6/bin:/usr/etc:/etc:/usr/games:/bin:/usr/bin:/usr/local/bin:/hpn/home/molinero/bin:/usr/local/frame/bin:/usr/afsws/bin:/usr/pubsw/apps/jdk1.2/bin:/usr/pubsw/bin:/usr/pubsw/X/bin:/sbin:/usr/sbin:/sbin:/opt/kde/bin:/home/molinero/bin/i586-unknown-linux/ns-allinone-2.1b4/bin:/usr/hpnbin/ns/ns-allinone-2.1b6/bin:/afs/ir/class/cs444i/ninja/ninja/rmi/util
POSTEDIT=''
PPID=6914
PRINTER=g342
PROMPT='?%n@%m:%B%~%b[%!]%(#.#.?) '
PROMPT2='%_> '
PROMPT3='?# '
PROMPT4='+ '
PS1='?%n@%m:%B%~%b[%!]%(#.#.?) '
PS2='%_> '
PS3='?# '
PS4='+ '
PSVAR=''
PURIFYOPTIONS='-cache-dir=/hpn/home/molinero/purify-cache
-cache-dir=/hpn/home/molinero/purify-cache '
PWD=/hpn/home/molinero
QTDIR=/usr/lib/qt-2.3.0
RANDOM=4875
READNULLCMD=more
RPROMPT=''
RPS1=''
SAVEHIST=200
SECONDS=11359
SESSION_MANAGER=local/manzanares.Stanford.EDU:/tmp/.ICE-unix/6644
SHELL=/bin/zsh
SHLVL=4
SPROMPT='zsh: correct '\''%R'\'' to '\''%r'\'' [nyae]? '
SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
STARTUPDEBUG=''
STAR_SPOOL_DIR=/tmp
SYSSTARTUP=/hpn/home/molinero/.inicial
TCL_LIBRARY=/usr/src/ns-allinone-2.1b7a/tcl8.3.2/library
TERM=xterm
TIMEFMT='%J  %U user %S system %P cpu %*E total'
TMPPREFIX=/tmp/zsh
TTSIM_HOME=/home/molinero/ttsim
TTY=/dev/pts/4
TTYIDLE=-1
UID=20246
UNAME_MACHINE=i686
UNAME_RELEASE=2.4.3-12
UNAME_SYSTEM=Linux
UNAME_VERSION='#1 Fri Jun 8 13:35:30 EDT 2001'
USER=molinero
USERNAME=molinero
VENDOR=redhat
VISUAL=emacs
WATCH=''
WATCHFMT='%n has %a %l from %m.'
WINDOWID=16777352
WM_PREF=''
WORDCHARS='*?_-.[]~=/&;!#$%^(){}<>'
X11HOME=/usr/X11R6
XDISTRIBUTE_DIR=/hpn/home/molinero/Xdistribute
XMCD_LIBDIR=/usr/local/lib/X11/xmcd/
XNLSPATH=/usr/X11/lib/X11/nls
XUSERFILESEARCHPATH=:/hpn/home/molinero/bin/%L/app-defaults/%N%C%S:/hpn/home/molinero/bin/%l/app-defaults/%N%C%S:/hpn/home/molinero/bin/app-defaults/%N%C%S:/hpn/home/molinero/bin/%L/app-defaults/%N%S:/hpn/home/molinero/bin/%l/app-defaults/%N%S:/hpn/home/molinero/bin/app-defaults/%N%S:/usr/X11R6/lib/X11/%L/app-defaults/%N%C%S:/usr/X11R6/lib/X11/%l/app-defaults/%N%C%S:/usr/X11R6/lib/X11/app-defaults/%N%C%S:/usr/X11R6/lib/X11/%L/app-defaults/%N%S:/usr/X11R6/lib/X11/%l/app-defaults/%N%S:/usr/X11R6/lib/X11/app-defaults/%N%S:/usr/X11R5/lib/X11/%L/app-defaults/%N%C%S:/usr/X11R5/lib/X11/%l/app-defaults/%N%C%S:/usr/X11R5/lib/X11/app-defaults/%N%C%S:/usr/X11R5/lib/X11/%L/app-defaults/%N%S:/usr/X11R5/lib/X11/%l/app-defaults/%N%S:/usr/X11R5/lib/X11/app-defaults/%N%S
ZSH_NAME=zsh
ZSH_VERSION=3.0.8
_=set
argv=(rmstar)
cdpath=()
fignore=('~' '#' .o)
fpath=(/usr/local/lib/zsh/func)
histchars='!^#'
i=/usr/X11R5/lib/X11
mailpath=()
manpath=(/usr/share/man /usr/man /man /usr/X11R6/man /usr/lib/perl5/man
/usr/kerberos/man /usr/local/man /usr/local/X11R5/man /usr/local/X11/man
/hpn/home/molinero/bin/man /usr/man /man /usr/local/man /usr/pubsw/man
/usr/pubsw/man /usr/pubsw/X/man /usr/afsws/man)
path=(/hpn/home/molinero/bin/scripts
/hpn/home/molinero/bin/i686-unknown-linux . /usr/bin/X11 /usr/X11R6/bin
/usr/etc /etc /usr/games /bin /usr/bin /usr/local/bin
/hpn/home/molinero/bin /etc/leland/bin /usr/bin /bin /usr/local/bin
/usr/ucb /usr/lang /usr/bin/X11 /hpn/home/molinero/bin/scripts
/hpn/home/molinero/bin/i686-unknown-linux . /usr/bin/X11 /usr/X11R6/bin
/usr/etc /etc /usr/games /bin /usr/bin /usr/local/bin
/hpn/home/molinero/bin /usr/local/frame/bin /usr/afsws/bin
/usr/pubsw/apps/jdk1.2/bin /usr/pubsw/bin /usr/pubsw/X/bin /sbin /usr/sbin
/sbin /opt/kde/bin
/home/molinero/bin/i586-unknown-linux/ns-allinone-2.1b4/bin
/usr/hpnbin/ns/ns-allinone-2.1b6/bin
/afs/ir/class/cs444i/ninja/ninja/rmi/util)
prompt='?%n@%m:%B%~%b[%!]%(#.#.?) '
psvar=()
signals=(EXIT HUP INT QUIT ILL TRAP ABRT BUS FPE KILL USR1 SEGV USR2 PIPE
ALRM TERM STKFLT CHLD CONT STOP TSTP TTIN TTOU URG XCPU XFSZ VTALRM PROF
WINCH IO PWR SYS RTMIN ZERR DEBUG)
status=0
watch=()


I use zsh as my login shell.




How reproducible:
Always

Steps to Reproduce:
1.declare the LC_* LANG and shell vars as I did
2.login using gdm
3.
	

Actual Results:  I could not log in using gdm

Expected Results:  login using gdm

Additional info:

similar effect using kdm, but I have not tested whether the solution would
work.
Comment 1 Havoc Pennington 2001-06-29 10:28:39 EDT
Reassigning to X, since it's a problem with the Xsession script.
Comment 2 Mike A. Harris 2001-07-28 07:34:40 EDT
This bug is a dupe of an open bug, but darned if I can find it..
Have to do some serious query action soon.  ;o)
Comment 3 Mike A. Harris 2001-07-30 03:28:04 EDT

*** This bug has been marked as a duplicate of 7860 ***

Note You need to log in before you can comment on or make changes to this bug.