Bug 464825 - F10-Beta - live usb - wrong keyboard preference
Summary: F10-Beta - live usb - wrong keyboard preference
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-settings-daemon (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
low
Target Milestone: ---
Assignee: Bastien Nocera
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 465369 (view as bug list)
Depends On:
Blocks: 464858
TreeView+ depends on / blocked
 
Reported: 2008-09-30 17:53 UTC by Michel Duquaine
Modified: 2018-04-11 13:10 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-01 03:37:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michel Duquaine 2008-09-30 17:53:50 UTC
Description of problem:


Version-Release number of selected component (if applicable):
F10-Beta

How reproducible:

Steps to Reproduce:

- F10-Beta-i686-Live.iso installed on a usb with tool "livecd-iso-to-disk"
- boot laptop acer aspire 2920 from usb 
- On the login screen, I select the language (Français (belgique)) and the keyboard (Belgique)
- When logged in the session, language is ok but not the keyboard: I have to go in the menu  Système/Préférences/Matériel/Clavier to adapt the keyboard
  
Actual results:
Wrong keyboard preference

Expected results:
Correct keyboard preference

Additional info:

Comment 1 Ray Strode [halfline] 2008-09-30 18:11:25 UTC
might be gdm or gnome-settings-daemon.  for now assigning to gnome-settings-daemon.

Comment 2 Bastien Nocera 2008-09-30 18:35:54 UTC
I have no idea how that's supposed to work. Jon, what does gdm actual do when you set the session keyboard in the login screen?

Comment 3 Lauri Nurmi 2008-09-30 20:54:06 UTC
To summarize the bug:

The keyboard layout selection has no effect on the Live CD. It is not related to just French or USB or Belgium.  The layout will always be en-US.

Comment 4 Matthias Clasen 2008-09-30 22:33:41 UTC
please report what 

env | grep GDM 

reports in the session ?

Comment 5 Lauri Nurmi 2008-09-30 22:50:47 UTC
For language Finnish, keyboard "Finland (Classic)":
GDM_KEYBOARD_LAYOUT=fi  classic
GDM_LANG=fi_FI.utf8
GDMSESSION=gnome

For language Finnish, keyboard "German":
GDM_KEYBOARD_LAYOUT=de
GDM_LANG=fi_FI.utf8
GDMSESSION=gnome

Comment 6 Matthias Clasen 2008-09-30 23:14:48 UTC
Ok, that proves that everything is fine as far as gdm is concerned.

If you add a keyboard indicator applet to your panel (or open the keyboard capplet), what layout does it show as selected ?

Comment 7 Lauri Nurmi 2008-09-30 23:27:55 UTC
The indicator applet says "USA".

Comment 8 Matthias Clasen 2008-09-30 23:48:28 UTC
Is gnome-settings-daemon running ? Which version ? 
This problem should be fixed by 

* Fri Sep  5 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.91-5
- Try harder to use the keyboard layout that gdm tells us

Or maybe not...

Comment 9 Matthias Clasen 2008-10-01 01:57:00 UTC
Here is what setxkbmap -print reports 

xkb_keymap {
        xkb_keycodes  { include "evdev+aliases(qwerty)" };
        xkb_types     { include "complete"      };
        xkb_compat    { include "complete"      };
        xkb_symbols   { include "pc+us+inet(evdev)+de(deadgraveacute):2+fi(classic):3+level3(ralt_switch_for_alts_toggle):1+level3(ralt_switch_for_alts_toggle):2+level3(ralt_switch_for_alts_toggle):3+group(alts_toggle)"     };
        xkb_geometry  { include "pc(pc104)"     };
};


This is after logging in with 'fi classic' selected in gdm, and three layouts configured in gnome: us, 'de  deadgraveacute', and 'fi classic'

Comment 10 Matthias Clasen 2008-10-01 03:37:53 UTC
Please try with gnome-settings-daemon-2.24.0-3.fc10.
That should fix it.

Comment 11 Matěj Cepl 2008-10-06 23:24:50 UTC
*** Bug 465369 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.