Bug 465369 - xorg ignores my default keyboard
xorg ignores my default keyboard
Status: CLOSED DUPLICATE of bug 464825
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-02 17:52 EDT by Dawid Pietrala
Modified: 2008-10-06 19:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-06 19:24:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dawid Pietrala 2008-10-02 17:52:34 EDT
Description of problem:

after installation of Fedora 10 beta i had to manually set my language and keyboard settings which were not taken from anaconda nor from my existing user's config files. in previous versions of Fedora the settings were taken from anaconda and from my user's settings.

the real problem however is that X window system does not honour my default keyboard setting which is Polish (set via Preferences in GNOME). whenever it starts GDM, i have to manually change it from USA to Polish. it remebers my language settings, though.

How reproducible:

always

Steps to Reproduce:
1. install Fedora 10 beta
2. be forced to become root in order to change your default language
3. set keyboard settings via GNOME utility
4. restart X or reboot
5. be happy to find out you need to change keyboard again
  
Actual results:

i had to change my language and keyboard settings after installation even though i used the same user with the same settings i used earlier in Fedora 9. so i had to become root in order to change the default language. i also changed keyboard but it does not honour it.

Expected results:

default language and keyboard settings should be already taken from anaconda. if it's not possible it should not force me to engage root to change the default language. moreover, it should honour my user's choice of keyboard.
Comment 1 Peter Hutterer 2008-10-02 20:25:42 EDT
If you set the language in gnome, does it work and does it work _after_ you log in the next time? i.e. is it just broken in gdm, or is it wrong all the time?
Comment 2 Peter Hutterer 2008-10-03 00:39:53 EDT
Possible duplicate: Bug 464825 - F10-Beta - live usb - wrong keyboard preference.

Although I admit that it sounds the other way round from what you are experiencing.
Comment 3 Dawid Pietrala 2008-10-03 11:47:12 EDT
yes, i think it's almost the same story.

today i started the system and in GDM the keyboard layout was Polish at last. in order to check if it's ok with gnome-settings-daemon-2.24.0-3.fc10.i386, i changed the layout to Spanish but no go. it's still Polish no matter whether i just restart X or reboot the whole system.
Comment 4 Matěj Cepl 2008-10-06 19:24:50 EDT

*** This bug has been marked as a duplicate of bug 464825 ***

Note You need to log in before you can comment on or make changes to this bug.