Bug 465174 - Incorrect DNS format on s390 causes traceback
Incorrect DNS format on s390 causes traceback
Status: CLOSED DUPLICATE of bug 472936
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.2
s390x Linux
high Severity high
: rc
: ---
Assigned To: Joel Andres Granados
Release Test Team
:
Depends On:
Blocks: 465175
  Show dependency treegraph
 
Reported: 2008-10-01 18:07 EDT by Brad Hinson
Modified: 2010-03-14 17:29 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
In prior versions of Red Hat Enterprise Linux, if DNS is specified in CONF or at console as " " (empty space) or ":" (colon with no addresses), Anaconda would error and crash. This feature includes format sanity checking into Anaconda, increasing stability.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-22 09:49:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to sanity check DNS servers entered (1.80 KB, patch)
2008-10-01 18:07 EDT, Brad Hinson
no flags Details | Diff

  None (edit)
Description Brad Hinson 2008-10-01 18:07:20 EDT
Created attachment 319168 [details]
Patch to sanity check DNS servers entered

Description of problem:
Problem discovered at customer site.  If DNS is specified in CONF or at console as " " (empty space) or ":" (colon with no addresses), anaconda dies with traceback:

The VNC server is now running.
Please connect to begin the install...
Starting graphical installation...
Traceback (most recent call last):
  File "/usr/bin/anaconda", line 1088, in ?
    id = instClass.installDataClass(extraModules, floppyDevice, configFileData, method)
  File "/usr/lib/anaconda/instdata.py", line 287, in __init__
    self.reset()
  File "/usr/lib/anaconda/instdata.py", line 60, in reset
    self.network = network.Network()
  File "/usr/lib/anaconda/network.py", line 204, in __init__
    self.primaryNS = resolv[1]
IndexError: list index out of range

To avoid this error, a properly formatted DNS address must be specified (either "" empty string, or one or more addresses separated by colon).  Anaconda should also have a sanity check on the DNS server(s) entered to avoid this traceback.

Version-Release number of selected component (if applicable):
anaconda-11.1.2.113-1

How reproducible:
100%

Steps to Reproduce:
1. Add either DNS=" " or DNS=":" to CMS CONF file on s390
2. Attempt any type of network install (NFS/HTTP/FTP), either graphical or text
3. Traceback occurs after entering install method, at the beginning of stage 2
Comment 1 RHEL Product and Program Management 2009-02-03 18:15:47 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 3 Steffen Maier 2009-04-02 13:27:08 EDT
(In reply to comment #0)
> Created an attachment (id=319168) [details]
> Patch to sanity check DNS servers entered

I would just like to add that this is also fixed by Bug 472936 or Bug 475346 respectively. Additionally, those bugs also include support for syntax checking of IPv6 DNS addresses (using comma as separator instead of colon, of course).
Comment 5 Shawn Wells 2009-07-08 17:30:21 EDT
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
In prior versions of Red Hat Enterprise Linux, if DNS is specified in CONF or at console as " " (empty space) or ":" (colon with no addresses), Anaconda would error and crash.  This feature includes format sanity checking into Anaconda, increasing stability.
Comment 8 Joel Andres Granados 2009-07-22 08:14:58 EDT
This might have been an error in the report.  Or the reproducers are, somehow, different.

Brad:
  Can you retest with your setup to see if the current anaconda takes care of the issue.
Comment 9 Brad Hinson 2009-07-22 09:49:13 EDT
Retested with 5.4, problem no longer occurs.  This was definitely fixed by Bug 472936 and/or Bug 475346 as Steffen mentioned.

Closing.

*** This bug has been marked as a duplicate of bug 472936 ***

Note You need to log in before you can comment on or make changes to this bug.