Bug 465199 - Fedora 10 Beta blocks in GDM on HP mini 2133
Fedora 10 Beta blocks in GDM on HP mini 2133
Status: CLOSED DUPLICATE of bug 446489
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-openchrome (Show other bugs)
10
All Linux
medium Severity high
: ---
: ---
Assigned To: Xavier Bachelot
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-01 23:40 EDT by William Lovaton
Modified: 2018-04-11 12:51 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-29 15:55:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X server log from the HP 2133 mini-note (48.55 KB, text/plain)
2008-10-02 10:46 EDT, William Lovaton
no flags Details

  None (edit)
Description William Lovaton 2008-10-01 23:40:37 EDT
Description of problem:
Testing the latest Fedora 10 Beta Live USB with one of those ultra portable HP 2133 Mini-Note.  It can boot fine in text mode but when it gets to GDM, it blocks completely, keyboard doesn't respond, the mouse doesn't respond, instead a pointer it shows a distorted big square and the whole screen is full of noise, you can see it's the GDM login screen but it is noisy.

I don't really know where to file this bug, if I hit Ctrl+Alt+F1 I can get to the prompt before X starts and prevent the blocking.  I then init 3 the system and it is usable.

I then starts X with:
$ X &

It shows a bare metal X session with the big distorted square as a pointer, the mouse doesn't respond but this time it doesn't block: I can get back to the text terminal.

In the console I can see the following:
New driver is "openchrome"
(==) Using default built-in configuration (30 lines)
(EE) open /dev/fb0: No such file or directory
(EE) [drm] drmOpen failed.
(EE) CHROME(0): [dri] DRIScreenInit failed.  Disabling DRI.
Freed 9834496 (pool 1)
expected keysym, got XF86Info: line 914 of inet
expected keysym, got XF86Info: line 914 of inet
expected keysym, got XF86Info: line 914 of inet

That's all.  The X session seems to work, I can start xclock and after around 30 secs the clock show up in the X session completely distorted.

All in all, I am unable to use Fedora 10 Beta in graphical mode which is quite bad.  Is this a known problem with this mini laptop??

I remember there was some page on fedoraproject.org about Fedora on Ultra Mobile PCs.  Where can I get more information about Fedora on this kind of computers??

The hardware specs according to Windows Vista is:
- Processor VIA C7-M 1.6 GHz
- 1 GB of RAM
- 100 GB of hard drive
- VIA Chrome9 HC IGP Family WDDM graphic adapter


Thanks a lot for your help.
Comment 1 Matěj Cepl 2008-10-02 06:48:09 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 William Lovaton 2008-10-02 10:35:21 EDT
The X server config file doesn't exists in Fedora, remember that in my original post the X server said this:
(==) Using default built-in configuration (30 lines)

I had to change inittab to runlevel 3 to use the mini-note reliably.  When I start X I now get more messages in the output:

New driver is "openchrome"
(==) Using default built-in configuration (30 lines)
(EE) open /dev/fb0: No such file or directory
(EE) [drm] drmOpen failed.
(EE) CHROME(0): [dri] DRIScreenInit failed.  Disabling DRI.
Freed 9834496 (pool 1)
expected keysym, got XF86Info: line 914 of inet
expected keysym, got XF86Info: line 914 of inet
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning:    Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols
>             Ignoring extra symbols
Errors from xkbcomp are not fatal to the X server
expected keysym, got XF86Info: line 914 of inet
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning:    Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols
>             Ignoring extra symbols
Errors from xkbcomp are not fatal to the X server

I'll attach the X server log later.
Comment 3 William Lovaton 2008-10-02 10:46:36 EDT
Created attachment 319246 [details]
X server log from the HP 2133 mini-note

Oddly enough, if I start two X apps it blocks completely, I have to force a shutdown.

I started xclock and it starts "fine" (distorted), I can go to the X server and back to the text console.  I then started xload, go to the X server and it blocks completely, I can't go back to the text console.
Comment 4 Xavier Bachelot 2008-10-16 15:02:05 EDT
There are a couple configuration options I'd like you to try.

Does disabling this particular bit of XAA help ?
Option "XaaNoImageWriteRect"

If it still doesn't work with the above option, does switching to EXA acceleration help (remove the above option) ?
Option "AccelMethod" "EXA"

If it's still not good with with only EXA, does disabling EXA composite help  ?
Option "AccelMethod" "EXA"
Option "ExaNoComposite"
Comment 5 William Lovaton 2008-10-17 08:52:50 EDT
(In reply to comment #4)
I tested all the variants you posted and all of them worked fine except for the mouse pointer which still is a big  distorted square.  The tip of the pointer is the upper left corner so I can move around and use the desktop.

Later on I'll try to post a picture of the screen.

What can be done about the mouse pointer?
Comment 6 Xavier Bachelot 2008-10-19 10:24:34 EDT
About the mouse pointer, try to switch to software cursor :
Option "SWCursor"
I'll see about disabling ARGB hardware cursor in a later build, but I'd like upstream to comment on that first, there's likely a more generic issue.
Comment 7 William Lovaton 2008-11-09 23:13:01 EST
Unfortunately I don't have the hardware anymore, it was borrowed by HP and I returned it a few days ago.  But still every single fix you said here in this bug report worked perfectly.  It's just a matter of getting it to auto detect the right setup so that regular users have a working system out of the box.

Thanks a lot for your help.
Comment 8 Bug Zapper 2008-11-25 22:26:42 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Xavier Bachelot 2008-12-29 15:55:23 EST

*** This bug has been marked as a duplicate of bug 446489 ***

Note You need to log in before you can comment on or make changes to this bug.