Bug 465230 - nscd crashes
nscd crashes
Status: CLOSED DUPLICATE of bug 476504
Product: Fedora
Classification: Fedora
Component: smbldap-tools (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Howarth
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-02 06:31 EDT by Marek Greško
Modified: 2009-03-01 07:03 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-01 07:03:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marek Greško 2008-10-02 06:31:24 EDT
Description of problem:
I get nscd crashed after short time of running. The problem is probably unrelated to bug 445656. Now I get crashes only on machine with ldap database of more the 33000 users.

Version-Release number of selected component (if applicable):
nscd-2.8-8.i386

How reproducible:
After running nscd it crashes after a while.

Steps to Reproduce:
1. Setup large ldap database with more then 33000 users.
2. Run nscd.
3. Wait for crash
  
Actual results:
Nscd crashes.

Expected results:
Nscd does not crash.

Additional info:
I see this in log (debuglevel 3):
14950: considering GETPWBYUID entry "99", timeout 1222941017
14950: considering GETPWBYUID entry "1000031", timeout 1222941002
14950: considering GETPWBYUID entry "57", timeout 1222941002
14950: considering GETPWBYUID entry "1031124", timeout 1222940986
14950: considering GETPWBYNAME entry "user22", timeout 1222941002
14950: remove GETPWBYNAME entry "8718678"
14950: handle_request: žiadosť prijatá (verzia = 2) z PID 15012
14950:  SHUTDOWN

Probably some timeout on ldap database occurs?
Comment 1 Jakub Jelinek 2008-10-02 13:35:04 EDT
More likely it just crashes inside of the nss_ldap module, which would make it a nss_ldap fault.  Either try to reproduce it without ldap, or get a core file and backtrace to show where it crashed.
Comment 2 Marek Greško 2008-10-03 07:26:03 EDT
It looks like it does not crash but regularly exits.

I tried to run:

ulimit -c unlimited
/usr/sbin/nscd -d
(under root - server-user was commented out)

and I got:

22766: provide access to FD 5, for passwd
22766: handle_request: žiadosť prijatá (verzia = 2) z PID 22790
22766:  GETFDHST
22766: provide access to FD 9, for hosts
22766: handle_request: žiadosť prijatá (verzia = 2) z PID 22790
22766:  GETFDGR
22766: provide access to FD 7, for group
22766: handle_request: žiadosť prijatá (verzia = 2) z PID 22804
22766:  SHUTDOWN

No core was generated.
Comment 3 Ulrich Drepper 2008-10-23 01:33:52 EDT
Seeing a SHUTDOWN command means that this is a request coming from the outside.  There is no other way the handle_request function is used.

You have to track down which script is issuing this command.  There is nothing in glibc which does this.
Comment 4 Marek Greško 2008-10-23 04:04:58 EDT
Probably smbldap-tools does.
Comment 5 Ulrich Drepper 2008-10-23 08:49:53 EDT
(In reply to comment #4)
> Probably smbldap-tools does.

Which package does this tool belong to?  Somebody reassign the bug, please.
Comment 6 Paul Howarth 2009-03-01 07:03:03 EST

*** This bug has been marked as a duplicate of bug 476504 ***

Note You need to log in before you can comment on or make changes to this bug.