Bug 465253 - [nomodeset] Fedora 10 Beta does not boot on Dell Inspiron 1501
[nomodeset] Fedora 10 Beta does not boot on Dell Inspiron 1501
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10KernelBlocker
  Show dependency treegraph
 
Reported: 2008-10-02 09:08 EDT by Matz
Modified: 2008-11-05 17:57 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-05 17:57:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Matz 2008-10-02 09:08:03 EDT
Description of problem:

I just tried out the Fedora 10 Beta live CD (x86_64). But I cannot boot it: After selecting "boot" the status bar appears and becomes white until the right side of the display. Then the screen gets black. Sometimes, I get no error at all, sometimes I get the following, repeated several times:

EXT3 -fs error (device dm-0) in ext3_new_inode: IO failure
EXT3 -fs error (device dm-0): ext3_get_inode_loc: unable to read inode block 

I successfully compared the sha1sums of .iso and SHA1SUM, as well as the md5sums of /dev/cdrom and the .iso.

Version-Release number of selected component (if applicable):

Fedora 10 Beta live x86_64

How reproducible:

Sometimes, I see some error messages, sometimes the screen just becomes black. But boot always fails.

Additional info:

My computer is a Dell Inspiron 1501 notebook. The component "kernel" is just a rough guess.

Any more information I can provide?
Comment 1 Alessandro Nazzani 2008-10-10 05:44:00 EDT
Same here, though I have yet to see those error messages: only black screen for me.

Unfortunately I don't have another 64bit PC at hand but will try as soon as I find one.
Comment 2 Artem 2008-10-10 06:30:15 EDT
I'm pretty sure, that blank screen is problem of mode settings, try add nomodeset option to grub. I have the same black screen on my Acer laptop with xpress1100 video (see bug #461545)
Comment 3 Alessandro Nazzani 2008-10-10 09:38:43 EDT
> try add nomodeset option to grub

That did the trick, thank you.
Comment 4 Christopher D. Stover 2008-10-22 16:31:46 EDT
Matz, have you tried what Artem said about adding the nomodeset option to GRUB as a kernel option?  Does this fix your problem?
Comment 5 Matz 2008-11-05 16:43:01 EST
Sorry for the late answer. The problem is solved now in the preview release, I can boot the live CD without any errors.

Note You need to log in before you can comment on or make changes to this bug.