Bug 465353 - anaconda says "connect to VNC" but does not tell where
anaconda says "connect to VNC" but does not tell where
Status: CLOSED DUPLICATE of bug 469439
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-02 17:04 EDT by Michal Jaegermann
Modified: 2008-11-01 19:18 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-01 19:18:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2008-10-02 17:04:37 EDT
Description of problem:

If one will try to start "VNC installation" while in "text mode"
then anaconda will say:

The VNC server is now running
Please manually connect your vnc client to begin the install.

but it leaves one guessing to connect where.  Especially
when network interfaces where configured by DHCP it may
be really non-obvious where a client may search for it.
True, it is possible to see the current configuration from
a shell running on another console but one has to be
aware of it and how to do this.  It would be really good
to have that information explicitly in a "connect" message.
A port in use also would be nice.

Version-Release number of selected component (if applicable):
anaconda version 11.4.1.40
Comment 1 Chris Lumens 2008-10-03 13:43:05 EDT
It's supposed to be doing just that, but the display code for VNC fell out of sync with the many changes that have been happening with networking.  This will be fixed in the next build of anaconda.  Thanks for the report.
Comment 2 Michal Jaegermann 2008-11-01 13:41:59 EDT
I retried that with images dated 20081031.  Now the message says:

Please manually connect your vnc client to 0.0.0.0:1 to begin the install.

Does not seem to be much of improvement (or I miss something?). Is this a garbled IPv6 address of a loopback or this is what it looks it is?

BTW - 'netstat -t -a' seems to show that something does listen on 0.0.0.0:5901 although not on 5900. 'netstat -u -a' reports only bootpc.
Comment 3 David Cantrell 2008-11-01 19:18:43 EDT

*** This bug has been marked as a duplicate of bug 469439 ***

Note You need to log in before you can comment on or make changes to this bug.