Bug 469439 - Invalid IPADDR shown when performing VNC install
Invalid IPADDR shown when performing VNC install
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
: 465353 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-31 16:41 EDT by James Laska
Modified: 2013-09-02 02:29 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-06 10:17:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (13.00 KB, text/plain)
2008-10-31 16:41 EDT, James Laska
no flags Details
0003-Make-sure-we-look-up-the-IP-address-for-the-correct.patch (6.56 KB, patch)
2008-10-31 22:26 EDT, David Cantrell
no flags Details | Diff

  None (edit)
Description James Laska 2008-10-31 16:41:14 EDT
Created attachment 322131 [details]
anaconda.log

Description of problem:

Doing a kickstart install, prompted for text or VNC.  I select VNC.  VNC is properly initiated, but the incorrect IP address is listed on the console

Version-Release number of selected component (if applicable):
anaconda 11.4.1.53

How reproducible:
only tried once so far

Steps to Reproduce:
1. Boot anaconda for a kickstart install
   > do not specific text, vnc, or cmdline
2. Select VNC when prompted for display preference
3. Select OK to accept VNC settings
  
Actual results:

20:32:11 Starting VNC...
20:32:12 The VNC server is now running.
20:32:12 

You chose to execute vnc with a password. 


20:32:12 Please manually connect your vnc client to ibm-sf2b-lp1.test.redhat.com:1 (0.0.0.0) to begin the install.
Press <enter> for a shell
Xlib:  extension "RANDR" missing on display ":1.0".
Xlib:  extension "RANDR" missing on display ":1.0".
20:32:12 Starting graphical installation...


Expected results:

20:32:12 Please manually connect your vnc client to ibm-sf2b-lp1.test.redhat.com:1 (192.168.32.22) to begin the install.

Additional info:

sh-3.2# cat /proc/cmdline                                            
ksdevice=link ip=dhcp console=hvc0 serial ks=hd:sda2:/ks.cfg 

#
Comment 1 David Cantrell 2008-10-31 22:24:59 EDT
This required updating vnc.py to work better with NetworkManager.  We were assuming that the first Network object in the netdevices was our active device, which may or may not be true.

Commit ID is 06ac083681b7ef8d32a93da650ec35257753ccc6.  This will be in the next build of anaconda or the one after that.

Attaching the patch for your reading pleasure.
Comment 2 David Cantrell 2008-10-31 22:26:05 EDT
Created attachment 322156 [details]
0003-Make-sure-we-look-up-the-IP-address-for-the-correct.patch
Comment 3 David Cantrell 2008-11-01 19:18:43 EDT
*** Bug 465353 has been marked as a duplicate of this bug. ***
Comment 4 James Laska 2008-11-06 10:17:28 EST
VERIFIED in anaconda-11.4.1.55-1.ppc

15:13:32 Starting VNC...
15:13:33 The VNC server is now running.
15:13:33 

WARNING!!! VNC server running with NO PASSWORD!
You can use the vncpassword=<password> boot option
if you would like to secure the server.


15:13:33 Please manually connect your vnc client to ibm-505-lp1.test.redhat.com:1 (192.168.33.2) to begin the install.
Xlib:  extension "RANDR" missing on display ":1.0".
Xlib:  extension "RANDR" missing on display ":1.0".
15:13:34 Starting graphical installation...
Comment 5 Michal Jaegermann 2008-11-06 11:56:03 EST
A stupid question without actually looking at the latest images.

> connect your vnc client to ibm-505-lp1.test.redhat.com:1

Is this ":1" really correct?  The last time I looked a vnc server was running on a port 5901 and not 1 as the above would suggest.  Or this 5900 offset is added automatically by a client?  Every vnc client?
Comment 6 Chris Lumens 2008-11-06 12:50:33 EST
That's a $DISPLAY number, not a port number.
Comment 7 Michal Jaegermann 2008-11-06 14:40:09 EST
> That's a $DISPLAY number, not a port number.

I would have a hard time to guess that and why I would really care?  OTOH when connecting with a vnc client an information which port to use could be rather vital.  See, for example, http://bobpeers.com/linux/vnc.php at the very bottom of that page.  What is shown by anconda is _really_ confusing.

Note You need to log in before you can comment on or make changes to this bug.