Bug 465358 - beagle's thunderbird leaves masses of files in /tmp
beagle's thunderbird leaves masses of files in /tmp
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: beagle (Show other bugs)
10
All Linux
medium Severity high
: ---
: ---
Assigned To: Adel Gadllah
Fedora Extras Quality Assurance
:
: 478296 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-02 17:30 EDT by Jeremy Fitzhardinge
Modified: 2009-01-07 16:49 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-07 16:49:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 556068 None None None Never

  None (edit)
Description Jeremy Fitzhardinge 2008-10-02 17:30:06 EDT
Description of problem:
When I enable beagle's thunderbird indexer, it leaves masses of files in of the form /tmp/tmp*.tmp.

Version-Release number of selected component (if applicable):
beagle-thunderbird-0.3.8-6.fc10.x86_64

How reproducible:
Always

Steps to Reproduce:
1.Enable beagle
2.Enable beagle-thunderbird
3.
  
Actual results:
Lots of files left in /tmp

Expected results:
No stray tmp files

Additional info:
Comment 1 Jeremy Fitzhardinge 2008-10-11 19:24:32 EDT
Changing to high severity, because this bug makes the package unusable.  It's equivalent to a severe memory leak.
Comment 2 Adel Gadllah 2008-10-12 07:31:28 EDT
I tryed to reproduce this but failed.
It creates files in tmp while indexing the mails but they get removed once the indexing is done. 
What might be happening in your case is that you shutdown thunderbird while it is indexing mails and therefore the files never get deleted.

Can you confirm this?
Comment 3 Jeremy Fitzhardinge 2008-10-12 12:55:08 EDT
No, that's definitely not the case.  If I enable the thunderbird beagle extension and leave it running for a little while - a minute or two - then there'll be new files accumulating in /tmp.  The longer it runs, the more files accumulate.

I use imap to fetch the mail, and I'm subscribed to high-traffic lists like the linux-kernel mailing list.
Comment 4 Adel Gadllah 2008-10-12 15:43:54 EDT
OK, please file an upstream bug (bugzilla.gnome.org) and post the bug id here.I wont have time to look at it in detail until next weekend, but if there is an upstream patch I can add it during the week.
Comment 5 Bug Zapper 2008-11-25 22:29:02 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Jeremy Fitzhardinge 2008-12-27 05:51:52 EST
This bug appears to be fixed upstream.  Could you pull it into F10?
Comment 7 Adel Gadllah 2008-12-28 09:32:58 EST
*** Bug 478296 has been marked as a duplicate of this bug. ***
Comment 8 Fedora Update System 2008-12-28 09:52:48 EST
beagle-0.3.8-14.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/beagle-0.3.8-14.fc10
Comment 9 Fedora Update System 2008-12-30 18:50:00 EST
beagle-0.3.8-14.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update beagle'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2008-11907
Comment 10 udo 2009-01-01 01:38:29 EST
Tested by removing the index.
Works well.
Comment 11 Fedora Update System 2009-01-07 16:49:35 EST
beagle-0.3.8-14.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.