Bug 465406 - No Hebrew support in F10-Beta
No Hebrew support in F10-Beta
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-03 02:24 EDT by Oron Peled
Modified: 2008-10-07 11:00 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-06 09:44:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of anaconda without Hebrew (66.22 KB, image/png)
2008-10-05 16:06 EDT, Oron Peled
no flags Details

  None (edit)
Description Oron Peled 2008-10-03 02:24:29 EDT
Description of problem:

 * Starting an install of F10-Beta, Hebrew does not
   appear in the language selection list.

 * Hebrew support was sent for anaconda in:
   https://bugzilla.redhat.com/show_bug.cgi?id=449238
   and committed later.

 * Anaconda Hebrew translation already jumped from ~11% in F9
   to 77% and we keep pushing (hope to get 100% by string freeze)

Version-Release number of selected component (if applicable):

 * Tested install from F10-Beta-Live-KDE


How reproducible:

 * After running "install to Hard Drive" and
   pressing "Next", there is no "Hebrew" in the
   selection list.
Comment 1 Jeremy Katz 2008-10-03 15:19:28 EDT
Hebrow shows up fine for me.  And then correctly switches to RTL and shows some translations with a regular install.

Can you provide a screenshot of what you're seeing?
Comment 2 Oron Peled 2008-10-05 16:06:28 EDT
Created attachment 319500 [details]
Screenshot of anaconda without Hebrew

As mentioned in the bug description, I tested Live-KDE image
(to save download time). If you suspect this is the cause
and Hebrew is available on the DVD image, I'll download
it and retest.

In any case it should be on the Live image as well IMO, since
this become one of the most common installation method for new,
less technical users which are the principal audience for the
localized install.

Thanks,
Comment 3 Jeremy Katz 2008-10-06 09:44:10 EDT
Please read the text at the top of the list -- that is the selection for keyboards, not languages.  The live installer picks up the language based on the environment it's running in so if you log in with Hewbrew as your language, your install will be Hebrew
Comment 4 Oron Peled 2008-10-07 03:03:58 EDT
I downloaded the (non-KDE) Live-CD for comparison and further
testing and found two different localization problems,
which are not limited to Hebrew:

1. Specific to KDE Live-CD:
   * Booting brings us directly to desktop (no login screen).
   * The KDE "System Settings" contain only "US English" in
     the "Add language" drop down list.
   * Logging out brings us to KDM which doesn't have any language selection
     (because of the way KDE handle languages...)
   * Manually opening Konsole and running:
        LANG=he_IL.UTF-8 /usr/sbin/liveinst
     works fine.
   * So it looks like the only way for (any) localized install is from the
     command line. Maybe this should be filed as a separate bug?

2. The (GNOME) Live-CD:
   * After testing I found there is a missmatch between GNOME locale
     definitions and the rest of the world:
     - Login to a Hebrew desktop.
     - Open a gnome-terminal.
     - The output of locale shows everything as he_IL.utf8
     - All linux apps I know use he_IL.UTF-8 (notice the case).
   * Results:
     - Running liveinst from this desktop does result in Hebrew install, but...
     - In the timezone selection it still defaults to New York
     - Running from gnome-terminal (after su of course):
           LANG=he_IL.UTF-8 /usr/sbin/liveinst
       or even
           LANG=he_IL /usr/sbin/liveinst
       behave as expected (Hebrew install and default Asia/Jerusalem timezone).
    * In my Hebrew support patch to anaconda:
         https://bugzilla.redhat.com/show_bug.cgi?id=449238
      I used the .UTF-8 notation like most other languages do.
      Should we fix GNOME or Anaconda?
Comment 5 Oron Peled 2008-10-07 03:38:15 EDT
Spinned off my second item to its own bug report:
 https://bugzilla.redhat.com/show_bug.cgi?id=465929
As it has nothing to do with Hebrew (same with e.g: de_DE)
Comment 6 Jeremy Katz 2008-10-07 11:00:09 EDT
The first is a bug in KDM/the KDE live images.  There's no way we can try to "guess" in anaconda what's been done as far as language selection already and thus just assume that the system is sane and you're in the right language already.

The second I'll look at a bit more (and follow-up in its bug)

Note You need to log in before you can comment on or make changes to this bug.