Bug 465411 - PDF build adds "1" characters into URLs, causing links to fail if people highlight and copy
PDF build adds "1" characters into URLs, causing links to fail if people high...
Status: CLOSED CURRENTRELEASE
Product: Publican
Classification: Community
Component: publican (Show other bugs)
2.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Fearn
Content Services Development
: Documentation
: 466308 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-03 02:50 EDT by Murray McAllister
Modified: 2015-01-04 17:35 EST (History)
4 users (show)

See Also:
Fixed In Version: 0.38
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-08 01:21:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
"1" characters in links (PDF output) (32.40 KB, image/png)
2008-10-03 02:50 EDT, Murray McAllister
no flags Details

  None (edit)
Description Murray McAllister 2008-10-03 02:50:58 EDT
Created attachment 319323 [details]
"1" characters in links (PDF output)

Version-Release number of selected component (if applicable):
* Red Hat Enterprise Linux Client release 5.2 (Tikanga)
* publican-0.37-0.el5
* fop-0.95-0.2.beta1.rh1.el5
* saxon-6.5.5-1jpp.3.el5
* evince-0.6.0-8.el5

How reproducible:
Always, when using "svn co http://svn.fedorahosted.org/svn/selinuxguide"

Steps to Reproduce:
1. svn co http://svn.fedorahosted.org/svn/selinuxguide
2. cd selinuxguide/community/trunk/SELinux_User_Guide
3. make pdf-en-US
4. See page 4
  
Actual results:
* "1" characters inserted into links (see attached).
* clicking on the link takes you to the correct page (no "1" characters in the link).
* right-click, copy link, also takes you to the correct page (no "1" characters in the link).

Highlighting the link, and then copying, copies the "1" characters, causing the link to fail.
Comment 1 Murray McAllister 2008-10-03 02:54:03 EDT
Issue occurs in publican-fedora-0.15-0.el5 and publican-redhat-0.15-0.el5. I have not tried anything else.
Comment 2 Jeff Fearn 2008-10-05 19:16:00 EDT
There is a bug in the way the URL is being escaped. It may take me some time to get to this as I am working on another system atm.

You can work around this bug by copying the URL in to the tag body.

e.g.

<ulink url="http://www.gentoo.org/proj/en/hardened/selinux/selinux-handbook.xml">http://www.gentoo.org/proj/en/hardened/selinux/selinux-handbook.xml</ulink>

or

<ulink url="http://www.gentoo.org/proj/en/hardened/selinux/selinux-handbook.xml">Gentoo SELinux Handbook</ulink>

This bug may have existed for sometime since, in my experience, very few people leave the ulink body empty.
Comment 3 Jeff Fearn 2008-10-08 01:21:57 EDT
Disabled ulink.hyphenate xsl variable, it was being set to 1.
Comment 4 Jeff Fearn 2008-10-09 17:44:23 EDT
*** Bug 466308 has been marked as a duplicate of this bug. ***
Comment 5 Fedora Update System 2008-10-16 18:43:54 EDT
publican-0.38-0.fc9,perl-XML-TreeBuilder-3.09-11.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/publican-0.38-0.fc9,perl-XML-TreeBuilder-3.09-11.fc9
Comment 6 Fedora Update System 2008-11-06 21:55:12 EST
publican-0.38-0.fc9, perl-XML-TreeBuilder-3.09-11.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.