Bug 465460 - Anaconda fails to migrate sda1 (vfat) if previous install used encrypted partitions
Anaconda fails to migrate sda1 (vfat) if previous install used encrypted part...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.3
ia64 Linux
medium Severity medium
: rc
: ---
Assigned To: Martin Sivák
Alexander Todorov
:
: 467812 468784 (view as bug list)
Depends On: 468162
Blocks: RHEL5u3_relnotes
  Show dependency treegraph
 
Reported: 2008-10-03 09:25 EDT by Alexander Todorov
Modified: 2010-10-23 00:56 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
In the Red Hat Enterprise Linux 5.3 Beta release, an upgrade from an earlier version of Red Hat Enterprise Linux 5 to the Beta will fail with the error: "An error occurred trying to migrate sda1. This problem is serious and the install cannot continue" This issue will be fixed in the next Beta update.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:37:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen shot of error message (52 bytes, text/plain)
2008-10-03 09:25 EDT, Alexander Todorov
no flags Details
anaconda.log (52 bytes, text/plain)
2008-10-03 09:27 EDT, Alexander Todorov
no flags Details
updates image to determine point of failure (1000.00 KB, application/octet-stream)
2008-10-03 11:16 EDT, David Lehman
no flags Details
anacdump.txt (339.81 KB, text/plain)
2008-10-10 15:16 EDT, Alexander Todorov
no flags Details

  None (edit)
Description Alexander Todorov 2008-10-03 09:25:29 EDT
Created attachment 319359 [details]
screen shot of error message

Description of problem:


Version-Release number of selected component (if applicable):
anaconda-11.1.2.133-1

How reproducible:
Always

Steps to Reproduce:
1) Install with default partitioning, select encrypted which creates one volume
group with encrypted PVs. system boots fine

2) do a second install which:
3) when asked for a pass phrase click cancel
4) leave the default partitioning scheme (remove all linux partitions) and do
NOT select encrypt system checkbox.

I can proceed with the install however while the partitions are being formatted
i see another error (see screen shot). Please advise if you need another bug
filed for it or we can track it in this one.  

Actual results:
error, installation can not continue, see screen shot

Expected results:
installation completes

Additional info:
Comment 1 Alexander Todorov 2008-10-03 09:27:22 EDT
Created attachment 319360 [details]
anaconda.log
Comment 2 Alexander Todorov 2008-10-03 09:28:27 EDT
/dev/sda1 vfat mounted under /boot/efi 

I can reproduce reliably on one system at least.
Comment 3 David Lehman 2008-10-03 11:16:46 EDT
Created attachment 319378 [details]
updates image to determine point of failure

Please try it again with this updates image. It should cause the full exception to be displayed so I can see what is happening instead of the message box.
Comment 4 Denise Dumas 2008-10-09 09:29:12 EDT
Alexander, did yoiu have any luck with the updates.img?
Comment 5 Alexander Todorov 2008-10-10 15:16:12 EDT
Created attachment 320050 [details]
anacdump.txt

Attaching requested file. Traceback is:

Traceback (most recent call first):
  File "/tmp/updates/fsset.py", line 994, in labelDevice
    raise SystemError, "dosfslabel failed on device %s: %s" % (devicePath, msg)
  File "/tmp/updates/fsset.py", line 1048, in migrateFileSystem
    self.labelDevice(entry, chroot)
  File "/tmp/updates/fsset.py", line 1985, in migrateFilesystems
    chroot)
  File "/usr/lib/anaconda/packages.py", line 127, in doMigrateFilesystems
    anaconda.id.fsset.migrateFilesystems (anaconda.rootPath)
  File "/usr/lib/anaconda/dispatch.py", line 201, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 124, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1151, in nextClicked
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 251, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 1178, in handleRenderCallback
    self.currentWindow.renderCallback()
SystemError: dosfslabel failed on device /tmp/sda1: /boot/efi  



/boot/efi is vfat and is only required on ia64
Comment 6 David Lehman 2008-10-10 15:36:27 EDT
What do you see on tty5 after the traceback occurs?
Comment 7 Alexander Todorov 2008-10-10 16:24:24 EDT
I'm connected via serial console so I don't think I can even get to tty5. If you tell me which file it's written to I will attach it.
Comment 8 David Lehman 2008-10-10 16:46:10 EDT
First, let me say that I don't see how this could possibly depend on encryption in any way.

Unfortunately, the tty5 messages do not get written to a file.
Comment 9 Denise Dumas 2008-10-17 11:27:30 EDT
Martin, assigned to you since you are located near the IA64 box. Can you please work on this Monday ASAP with atodorov?
Comment 12 Martin Sivák 2008-10-20 11:10:18 EDT
After some poking around, we figured what causes the error message.. we are still not sure what causes the underlying error though.

(the logs are not part of the tree, use updates image below)

updates image to add more verbosity (and to see the traceback):
http://msivak.fedorapeople.org/anaconda/label.img

relevant parts of the anaconda.log:
14:46:34 DEBUG   : Launching <fsset.FATFileSystem instance at 0x2000000002a6fcf8
  fsystem: vfat format: 0                                                       
  ismounted: 1  options: 'defaults'                                             
  bytesPerInode: 4096 label: /boot/efi                                          
 /mnt/sysimage                             

14:46:34 DEBUG   : Launching dosfslabel /tmp/sda1 /boot/efi1                    
14:46:34 DEBUG   : Result of dosfslabel /tmp/sda1 /boot/efi1 is 1               
14:46:34 ERROR   : dosfslabel failed on device /tmp/sda1: /boot/efi1

anacdump.txt:
see the traceback above, it is identical

pieces and bit from playing with the vt2 console:
sh-3.2# dosfslabel /tmp/sda1 /boot/efi1         
sh-3.2# echo $?                                 
1
sh-3.2# dosfslabel /tmp/sda1           
/boot/efi1 

sh-3.2# parted  /dev/sda -l   

Model: HP 146 G MAX3147NC (scsi)
Disk /dev/sda: 147GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt

Number  Start   End    Size   File system  Name  Flags
 1      17.4kB  105MB  105MB  fat16              boot 
 2      105MB   147GB  147GB                     lvm
Comment 13 Alexander Todorov 2008-10-21 02:35:24 EDT
*** Bug 467812 has been marked as a duplicate of this bug. ***
Comment 20 Denise Dumas 2008-10-22 17:53:51 EDT
Ryan, I added a release note that is only going to be needed for the Beta.
Comment 21 Denise Dumas 2008-10-22 17:53:51 EDT
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
In the RHEL 5.3 Beta release, an upgrade from an earlier version of RHEL 5 to the Beta will fail with the error:

"An error occurred trying to migrate sda1.  This problem is serious and the
install cannot continue"

This problem will be fixed in the next Beta update.
Comment 23 Ryan Lerch 2008-10-22 22:36:54 EDT
Release note updated. If any revisions are required, please set the 
"requires_release_notes"  flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

Diffed Contents:
@@ -1,6 +1,6 @@
-In the RHEL 5.3 Beta release, an upgrade from an earlier version of RHEL 5 to the Beta will fail with the error:
+In the Red Hat Enterprise Linux 5.3 Beta release, an upgrade from an earlier version of Red Hat Enterprise Linux 5 to the Beta will fail with the error:
 
 "An error occurred trying to migrate sda1.  This problem is serious and the
 install cannot continue"
 
-This problem will be fixed in the next Beta update.+This issue will be fixed in the next Beta update.
Comment 24 Stepan Kasal 2008-10-29 08:27:35 EDT
*** Bug 468784 has been marked as a duplicate of this bug. ***
Comment 25 Denise Dumas 2008-10-29 10:15:53 EDT
This is fixed by 468162, Stefan's update of the dosfstools package. But in order to reference this in the errata and more accurately reflect the actual problem, we would like to mark this as a blocker.
Comment 32 errata-xmlrpc 2009-01-20 16:37:19 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0164.html

Note You need to log in before you can comment on or make changes to this bug.