Bug 468784 - Regression: : dosfslabel failed on device /tmp/cciss/c0d2p1: /boot/efi1
Regression: : dosfslabel failed on device /tmp/cciss/c0d2p1: /boot/efi1
Status: CLOSED DUPLICATE of bug 465460
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: dosfstools (Show other bugs)
5.3
ia64 Linux
medium Severity medium
: rc
: ---
Assigned To: Stepan Kasal
BaseOS QE
: Regression
Depends On: 468162
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-27 19:25 EDT by Wade Mealing
Modified: 2008-10-29 09:30 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-29 08:27:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wade Mealing 2008-10-27 19:25:36 EDT
Description of problem:

While installing whether through text mode or vnc, if you are installing to a disk with an installation of rhel5.3 alpha1 already on it, it gets towards the end of the format and errors with "An Error occurred trying to mirage cciss/c0d1p1. This problem is serious, and the install cannot continue."

How reproducible:
Install rhel5.3 alpha1 on a disk, then go through and do another install on that same disk.

Steps to Reproduce:
As described above.

Actual results:
Error, must reboot.

Expected results:
finish formatting disk and continue with installation.

Additional info:

At some points this also happens later in the install process, after package selection. Wiping the disk of course fixes the problem.

Traceback (most recent call first):                                            
 File "/usr/lib/anaconda/fsset.py", line 994, in labelDevice
   raise SystemError, "dosfslabel failed on device %s: %s" % (devicePath, msg)
 File "/usr/lib/anaconda/fsset.py", line 1830, in labelEntry
   entry.fsystem.labelDevice(entry, chroot)
 File "/usr/lib/anaconda/fsset.py", line 1954, in makeFilesystems
   self.labelEntry(entry, chroot)
 File "/usr/lib/anaconda/packages.py", line 162, in turnOnFilesystems
   anaconda.id.fsset.makeFilesystems (anaconda.rootPath)
 File "/usr/lib/anaconda/dispatch.py", line 201, in moveStep
   rc = stepFunc(self.anaconda)
 File "/usr/lib/anaconda/dispatch.py", line 124, in gotoNext
   self.moveStep()
 File "/usr/lib/anaconda/text.py", line 719, in run
   anaconda.dispatch.gotoNext()
 File "/usr/bin/anaconda", line 1002, in ?
   anaconda.intf.run(anaconda)
SystemError: dosfslabel failed on device /tmp/cciss/c0d2p1: /boot/efi1 

This is seen every time you install on a system with a previously existing install and select the default partitioning method:

"Remove linux partitions on selected drives and create default layout."

However, if you select:

"Remove all partitions on selected drives and create default layout."

the install works OK.
Comment 2 RHEL Product and Program Management 2008-10-28 13:59:53 EDT
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 3 Stepan Kasal 2008-10-29 08:15:31 EDT
fixed in dosfstools-2.11-7.el5
Comment 4 Stepan Kasal 2008-10-29 08:27:35 EDT

*** This bug has been marked as a duplicate of bug 465460 ***

Note You need to log in before you can comment on or make changes to this bug.