This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 465470 - gtk-window-decorator doesn't layout window border widgets correctly
gtk-window-decorator doesn't layout window border widgets correctly
Status: CLOSED DUPLICATE of bug 446457
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-03 10:27 EDT by Thomas J. Baker
Modified: 2008-10-24 16:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-24 16:46:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
compiz showing altered window border button layout (738.14 KB, image/png)
2008-10-03 10:27 EDT, Thomas J. Baker
no flags Details
metacity showing correct window border button layout (593.50 KB, image/png)
2008-10-03 10:29 EDT, Thomas J. Baker
no flags Details

  None (edit)
Description Thomas J. Baker 2008-10-03 10:27:30 EDT
Created attachment 319369 [details]
compiz showing altered window border button layout

On an up to date beta+current rawhide laptop with intel graphics, compiz/gtk-window-decorator doesn't lay out the minimize, maximize, and close buttons correctly (meaning like metacity). I had a day where compiz was crashing my x server and had to go back to metacity. I thought that the default theme had changed the layout of the window border buttons. Turns out that they hadn't changed and compiz was drawing them incorrectly. Screenshots showing problem attached. Maybe a good excuse to upgrade to compiz 0.7.8?
Comment 1 Thomas J. Baker 2008-10-03 10:29:55 EDT
Created attachment 319370 [details]
metacity showing correct window border button layout
Comment 2 Thomas J. Baker 2008-10-08 16:47:22 EDT
I've verified that compiz 0.7.8 fixes the problem. I rebuilt most of the compiz rpms with the 0.7.8 version and it fixed the gtk-window-decorator drawing problem.
Comment 3 Peter Robinson 2008-10-13 19:45:22 EDT
So is it planned for rawhide?
Comment 4 Adel Gadllah 2008-10-24 16:46:50 EDT

*** This bug has been marked as a duplicate of bug 446457 ***

Note You need to log in before you can comment on or make changes to this bug.