Bug 446457 - Decorator buttons (minimize, max, close) moved....
Summary: Decorator buttons (minimize, max, close) moved....
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: compiz
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Kristian Høgsberg
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 465470 466103 (view as bug list)
Depends On:
Blocks: F10DesktopTarget
TreeView+ depends on / blocked
 
Reported: 2008-05-14 17:19 UTC by Tom London
Modified: 2018-04-11 09:33 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-10-22 15:36:12 UTC


Attachments (Terms of Use)
Screenshoot showing "strangely" placed decorator buttons (41.83 KB, image/png)
2008-05-14 17:19 UTC, Tom London
no flags Details

Description Tom London 2008-05-14 17:19:14 UTC
Description of problem:
compiz-gnome-0.7.2-4.fc10.i386 displays the minimize, maximize and close buttons
"funny".  They are no longer "right aligned" to the top right border.

Image attached....

Version-Release number of selected component (if applicable):
compiz-gnome-0.7.2-4.fc10.i386

How reproducible:
Every time.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Tom London 2008-05-14 17:19:14 UTC
Created attachment 305386 [details]
Screenshoot showing "strangely" placed decorator buttons

Comment 2 Tom London 2008-05-21 18:08:39 UTC
Tested with metacity..... works fine there.

Comment 3 Matěj Cepl 2008-05-27 13:26:30 UTC
The same version of compiz and same result.

Comment 4 Tom London 2008-07-21 13:42:24 UTC
Same results with current rawhide: compiz-gnome-0.7.6-9.fc10.i386 (and all
previous compiz updates since compiz-gnome-0.7.2-4.fc10.i386)




Comment 5 chris desjardins 2008-10-13 20:32:11 UTC
I am also experiencing this issue and it's continues to be present on compiz-gnome-0.7.6-11.fc10.i386

Comment 6 Adel Gadllah 2008-10-14 17:17:37 UTC
There have been no changes in compiz (related to this) for a long time.
0.7.2 is the same which we ship in f9.

Is there a version where this does not happen? 
Does it happen with other themes than nodoka?

Comment 7 Tom London 2008-10-14 17:27:04 UTC
This has been this way since original report (14 May).

I started Appearance in System->Preferences->Look and Feel, and switched my theme to "glider".  Same issue.

Comment 8 chris desjardins 2008-10-14 17:31:11 UTC
I can also confirm that this occurs regardless of the window border selected.

Comment 9 Ryan James 2008-10-14 18:57:47 UTC
it is a problem with gtk-window-decorator.  the buttons appear as normal if /apps/gwd/use_metacity_theme is unchecked in gconf enabling the cairo window decorator, or if an emerald theme is used.

Comment 10 Will Woods 2008-10-15 13:32:21 UTC
If there haven't been changes in compiz-gnome, then perhaps the bug is caused by a behaviour change in one of the libraries that gtk-window-decorator uses.

What are the likely culprits? How can we debug this further?

Comment 11 Adel Gadllah 2008-10-15 20:11:48 UTC
(In reply to comment #10)
> If there haven't been changes in compiz-gnome, then perhaps the bug is caused
> by a behaviour change in one of the libraries that gtk-window-decorator uses.
> 
> What are the likely culprits? How can we debug this further?

I suspect a change in metacity and/or libwnck.

Can you please try this build (one its done) https://koji.fedoraproject.org/koji/taskinfo?taskID=882778 (backported a patch from upstream which might fix it)

Comment 12 Adel Gadllah 2008-10-15 20:18:24 UTC
Sorry patch was incomplete use this one: http://koji.fedoraproject.org/koji/taskinfo?taskID=882798

Comment 13 Tom London 2008-10-15 20:41:00 UTC
Updated to 0.7.6-12.fc10.x86_64:

compiz-fusion-gnome-0.7.6-6.fc10.x86_64
compizconfig-python-0.7.6-1.fc10.x86_64
compiz-0.7.6-12.fc10.x86_64
compiz-fusion-0.7.6-6.fc10.x86_64
compiz-gnome-0.7.6-12.fc10.x86_64

But no change observed.

Comment 14 Tom London 2008-10-15 20:49:39 UTC
BTW, I logged off and logged back in after updating, but no change.

Comment 15 Adel Gadllah 2008-10-17 16:14:03 UTC
Please post the output of

gconftool-2  --get /apps/metacity/general/button_layout

Comment 16 Tom London 2008-10-17 16:17:45 UTC
[tbl@tlondon ~]$ gconftool-2 --get /apps/metacity/general/button_layout
menu:minimize,maximize,close
[tbl@tlondon ~]$

Comment 17 Adel Gadllah 2008-10-17 19:18:46 UTC
Please test again with this build: http://koji.fedoraproject.org/koji/taskinfo?taskID=886685

Comment 18 Tom London 2008-10-17 20:06:15 UTC
Installed above:
[tbl@tlondon ~]$ rpm -qa compiz\*
compiz-fusion-gnome-0.7.6-6.fc10.x86_64
compizconfig-python-0.7.6-1.fc10.x86_64
compiz-gnome-0.7.6-13.fc10.x86_64
compiz-fusion-0.7.6-6.fc10.x86_64
compiz-0.7.6-13.fc10.x86_64
[tbl@tlondon ~]$ 

No change. 

This time I installed, logged off, logged back on, started a few windows and started fusion-icon.

Comment 19 Adel Gadllah 2008-10-22 14:50:15 UTC
This build should work: http://koji.fedoraproject.org/koji/taskinfo?taskID=895693

(The metacity version detection wasn't correct so the fix was not used at all)

Please retest.

Comment 20 Tom London 2008-10-22 15:03:41 UTC
Yes!  That does it.

I downloaded and installed; and using fusion-icon's "reload window manager" selection, the screen got redrawn with the buttons in the "proper" place!

Thanks!

I'll test with a reboot, and report here if any issues.

Comment 21 Adel Gadllah 2008-10-22 15:36:12 UTC
Thanks for testing.

I have built compiz-0.7.6-14.fc10 with the fix which should hit rawhide soon.

Comment 22 Thomas J. Baker 2008-10-22 18:58:11 UTC
Apparently this bug has many duplicates (#466103 and #465470). I reported in the latter that upgrading to 0.7.8 fixed it. Any reason why we're not just getting 0.7.8 at least for F10? I've built it for both F9 and F10 and it seems to work as well as 0.7.6.

Comment 23 Adel Gadllah 2008-10-23 14:19:57 UTC
(In reply to comment #22)
> Apparently this bug has many duplicates (#466103 and #465470). I reported in
> the latter that upgrading to 0.7.8 fixed it. Any reason why we're not just
> getting 0.7.8 at least for F10? I've built it for both F9 and F10 and it seems
> to work as well as 0.7.6.

Yes there is a simple reason... its a rather big update which is to risky at this point in the release cycle.

However we can build and push into updates-testing and later updates after the F10 release.

Comment 24 Adel Gadllah 2008-10-24 20:46:50 UTC
*** Bug 465470 has been marked as a duplicate of this bug. ***

Comment 25 Adel Gadllah 2008-10-24 20:48:19 UTC
*** Bug 466103 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.