Bug 465547 - vt1 is not properly started
vt1 is not properly started
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: plymouth (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Blocker/F10FinalBlocker
  Show dependency treegraph
 
Reported: 2008-10-03 16:14 EDT by Bruno Wolff III
Modified: 2008-10-10 14:18 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-06 16:02:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
tty1 (282 bytes, text/plain)
2008-10-03 16:39 EDT, Bruno Wolff III
no flags Details
tty2 (306 bytes, text/plain)
2008-10-03 16:40 EDT, Bruno Wolff III
no flags Details
Modified tty1 (306 bytes, text/plain)
2008-10-03 17:18 EDT, Bruno Wolff III
no flags Details

  None (edit)
Description Bruno Wolff III 2008-10-03 16:14:39 EDT
Description of problem:
Recently I noticed that doing ctrl alt f1 doesn't get me a login prompt. Instead I see the output from the boot sequence. Hitting return scrolls the screen so it looks like some process is seeing the input. Vts 2-6 seem to work normally and vt7 gets me back to X.

Version-Release number of selected component (if applicable):
initscripts-8.83-1.x86_64
kernel-2.6.27-0.382.rc8.git4.fc10.x86_64
upstart-0.3.9-19.fc10.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Boot to X
2. ctrl alt f1
3.
  
Actual results:
No login prompt

Expected results:
Login prompt

Additional info:
Comment 1 Ray Strode [halfline] 2008-10-03 16:24:17 EDT
can you attach /etc/inittab and /etc/grub.conf

what's the output of ls -l /etc/event.d ?

Do you use gdm or kdm or something else ?
Comment 2 Bruno Wolff III 2008-10-03 16:34:43 EDT
I use gdm-2.24.0-8.fc10.x86_64.

[root@cerberus bruno]# ls -l /etc/event.d
total 104
-rw-r--r-- 1 root root  260 2008-09-30 14:05 control-alt-delete
-rw-r--r-- 1 root root  299 2008-05-13 10:27 logd
-rw-r--r-- 1 root root  195 2008-09-30 14:05 prefdm
-rw-r--r-- 1 root root  265 2008-09-30 14:05 quit-plymouth
-rw-r--r-- 1 root root  545 2008-09-30 14:05 rc0
-rw-r--r-- 1 root root  639 2008-09-30 14:05 rc1
-rw-r--r-- 1 root root  396 2008-09-30 14:05 rc2
-rw-r--r-- 1 root root  396 2008-09-30 14:05 rc3
-rw-r--r-- 1 root root  396 2008-09-30 14:05 rc4
-rw-r--r-- 1 root root  396 2008-09-30 14:05 rc5
-rw-r--r-- 1 root root  415 2008-09-30 14:05 rc6
-rw-r--r-- 1 root root  803 2008-09-30 14:05 rcS
-rw-r--r-- 1 root root  505 2008-09-30 14:05 rcS-sulogin
-rw-r--r-- 1 root root 1832 2008-09-08 08:44 readahead-collector.event
-rw-r--r-- 1 root root  671 2008-09-08 08:44 readahead-disable-services.event
-rw-r--r-- 1 root root 1137 2008-09-08 08:44 readahead.event
-rw-r--r-- 1 root root  707 2008-09-30 14:05 serial
-rw-r--r-- 1 root root  462 2008-09-30 14:05 sulogin
-rw-r--r-- 1 root root   80 2008-08-16 13:47 svscanboot
-rw-r--r-- 1 root root  282 2008-09-30 14:05 tty1
-rw-r--r-- 1 root root  306 2008-09-30 14:05 tty2
-rw-r--r-- 1 root root  306 2008-09-30 14:05 tty3
-rw-r--r-- 1 root root  306 2008-09-30 14:05 tty4
-rw-r--r-- 1 root root  306 2008-09-30 14:05 tty5
-rw-r--r-- 1 root root  306 2008-09-30 14:05 tty6
-rw-r--r-- 1 root root  377 2008-07-24 16:09 vpnc-cleanup

[root@cerberus bruno]# ps auxww|grep mingetty
root      2982  0.0  0.0   3936   504 tty4     Ss+  15:01   0:00 /sbin/mingetty tty4
root      2983  0.0  0.0   3936   508 tty5     Ss+  15:01   0:00 /sbin/mingetty tty5
root      2990  0.0  0.0   3936   508 tty2     Ss+  15:01   0:00 /sbin/mingetty tty2
root      2991  0.0  0.0   3936   508 tty3     Ss+  15:01   0:00 /sbin/mingetty tty3
root      2992  0.0  0.0   3936   508 tty6     Ss+  15:01   0:00 /sbin/mingetty tty6
root      6765  0.0  0.0  84748   788 pts/1    S+   15:34   0:00 grep mingetty
Comment 3 Bruno Wolff III 2008-10-03 16:39:41 EDT
Created attachment 319421 [details]
tty1

There seems to be a potentially significant difference between tty1 and the others.
Comment 4 Bruno Wolff III 2008-10-03 16:40:09 EDT
Created attachment 319422 [details]
tty2
Comment 5 Bruno Wolff III 2008-10-03 17:18:48 EDT
Created attachment 319426 [details]
Modified tty1

Adding "start on started prefdm" to tty1 (as in the attached file) fixed the problem I was seeing. I don't know if there may have been some reason not to include that as tty1 is a bit special.
Comment 6 Ray Strode [halfline] 2008-10-04 17:28:20 EDT
One change we're trying to make is for tty1 be the primary console for the user.

So in runlevel 3 it should be a getty, and in runlevel 5 it should be GDM/X.

I unfortunately screwed this change up, so only users with graphical bootup (The "spinfinity" animation) are getting that behavior, and everyone else (most users) are getting a broken behavior where tty1 isn't a getty or GDM/X in runlevel 5.

Moving to plymouth.
Comment 7 Ray Strode [halfline] 2008-10-06 16:02:33 EDT
This should be fixed now.
Comment 8 Bruno Wolff III 2008-10-06 18:44:49 EDT
I tested this and it seems to work. ctrl alt f1 switches to X instead of ctrl alt f7.
I did need to run mkinitrd after installing the plymouth update to see the change.
Comment 9 Ray Strode [halfline] 2008-10-10 14:18:31 EDT
*** Bug 466492 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.