Bug 466492 - ctrl-alt-f1 to tty1 doesn't work
ctrl-alt-f1 to tty1 doesn't work
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: F10Target F10DesktopTarget
  Show dependency treegraph
 
Reported: 2008-10-10 10:46 EDT by Mads Kiilerich
Modified: 2015-01-14 18:21 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-23 10:07:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mads Kiilerich 2008-10-10 10:46:20 EDT
Description of problem:
Usually, when I pressed ctrl-alt-f1 in runlevel 5 I got a console.

Now tty1 is black - tty2-6 works fine. (Aparently with the new modelineset consoles are used - nice but slow ...)

In runlevel 3 then tty1 looks fine but is dead. The other ones works fine.

Version-Release number of selected component (if applicable):
initscripts-8.83-1.i386
xorg-x11-drv-radeonhd-1.2.1-3.9.20080917git.fc10.i386

Expected results:
Always text console on ctrl-alt-f1
Comment 1 Bill Nottingham 2008-10-10 10:49:16 EDT
What version of plymouth do you have installed?
Comment 2 Ray Strode [halfline] 2008-10-10 14:18:31 EDT
This was fixed in 

plymouth-0.5.0-0.2008.10.06.-1

If you install the latest plymouth and run

/sbin/mkinitrd -f /boot/$(uname -r).img $(uname -r)

to rebuild your initrd (or install a new kernel) then this problem should go away.

I'm marking this as a duplicate of bug 465547 but if after upgrading you still see a problem, please reopen.

*** This bug has been marked as a duplicate of bug 465547 ***
Comment 3 Mads Kiilerich 2008-10-10 18:13:41 EDT
Partially confirmed. (Todays plymouth-0.6.0-0.2008.10.08.1.fc10.i386 had been installed together with a new kernel, but apparently the kernels initrd was made before the new plymouth was installed. Reinstalling kernel made it work.)

Primary console is now on c-a-f1. Very nice!

BUT after logout (and thus restart of the X server?) it is back on c-a-f7 and c-a-f1 is blank.

Reopening.
Comment 4 Ray Strode [halfline] 2008-10-10 19:25:21 EDT
ah, good catch.  Thank you.
Comment 5 Mads Kiilerich 2008-10-13 07:13:41 EDT
When booting directly to runlevel 3 then tty1 is dead too.
Comment 6 Mads Kiilerich 2008-10-15 19:29:34 EDT
I withdraw comment #5. It was either a bogus report or it has been fixed.

(There is however an interesting corner case when I start in runlevel 3 and logs into tty1 (the 0th tty), and then changes to runlevel 5 and X steals my tty where I had something _very_ important running. Perhaps it would be tast to take the first unused tty - also when changing user from within X and thus starting an extra X server ...)

the ":0 jumps to tty7" probably remains.
Comment 7 Mads Kiilerich 2008-10-16 07:29:37 EDT
I have created Bug 467207 to tracking runlevel 3 behaviour.
Comment 8 Mads Kiilerich 2008-10-23 08:25:01 EDT
Ray: Has this in your opinion been fixed? I think so.

Perhaps except the corner case I mention in comment #6?
Comment 9 Ray Strode [halfline] 2008-10-23 10:07:45 EDT
Yea, I think so.

We may want to file comment 6 is a separate bug report.
Comment 10 Mads Kiilerich 2008-10-23 13:34:16 EDT
Oh. The scenario from comment 6 is no issue. Apparently X isn't started on tty1 if it has been used - in that case tty7 is used instead. That could be related to bug 467207 ...

Note You need to log in before you can comment on or make changes to this bug.