Bug 465633 - NetworkManager RPM upgrade clobbers nm-system-settings.conf
Summary: NetworkManager RPM upgrade clobbers nm-system-settings.conf
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 480511 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-10-04 21:31 UTC by Martin Ebourne
Modified: 2009-03-08 19:32 UTC (History)
4 users (show)

Fixed In Version: 0.7.0.99-1.fc10
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-03-08 19:32:47 UTC
Type: ---


Attachments (Terms of Use)

Description Martin Ebourne 2008-10-04 21:31:12 UTC
Description of problem:
/etc/NetworkManager/nm-system-settings.conf is overwritten every time the NetworkManager RPM is upgraded.

Version-Release number of selected component (if applicable):
NetworkManager-0.7.0-0.11.svn4022.4.fc9.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Edit /etc/NetworkManager/nm-system-settings.conf to read:
[main]
plugins=keyfile
2. Upgrade NetworkManager
3. /etc/NetworkManager/nm-system-settings.conf has been overwritten with:
[main]
plugins=ifcfg-fedora
  
Expected results:
Configuration file should be preserved.

Additional info:

Comment 1 Dan Williams 2008-10-20 02:45:21 UTC
Yeah, shouldn't be doing this even though the keyfile plugin isn't quite ready for use yet.

Comment 2 Martin Ebourne 2008-12-01 21:48:42 UTC
Any chance of a fix for this one? NetworkManager-0.7.0-0.12.svn4326.fc10 has just broken it again. Should be a simple as %config(noreplace) hopefully.

Comment 3 Martin Ebourne 2009-01-10 10:35:39 UTC
NetworkManager-0.7.0-1.git20090102.fc10 clobbered it again. What is stopping the trivial fix?

Comment 4 Martin Ebourne 2009-01-21 23:56:53 UTC
*** Bug 480511 has been marked as a duplicate of this bug. ***

Comment 5 Fedora Update System 2009-02-07 22:22:25 UTC
NetworkManager-0.7.0-2.git20090207.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-1471

Comment 6 Fedora Update System 2009-02-24 20:49:37 UTC
NetworkManager-0.7.0.97-5.git20090220.fc10, NetworkManager-openconnect-0.7.0.97-1.fc10, NetworkManager-pptp-0.7.0.97-1.fc10, NetworkManager-openvpn-0.7.0.97-1.fc10, NetworkManager-vpnc-0.7.0.97-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager NetworkManager-openconnect NetworkManager-pptp NetworkManager-openvpn NetworkManager-vpnc'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-1985

Comment 7 Fedora Update System 2009-02-28 03:24:09 UTC
NetworkManager-0.7.0.98-1.git20090225.fc10, NetworkManager-openconnect-0.7.0.97-1.fc10, NetworkManager-pptp-0.7.0.97-1.fc10, NetworkManager-openvpn-0.7.0.97-1.fc10, NetworkManager-vpnc-0.7.0.97-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager NetworkManager-openconnect NetworkManager-pptp NetworkManager-openvpn NetworkManager-vpnc'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-1985

Comment 8 Fedora Update System 2009-03-06 17:34:32 UTC
NetworkManager-0.7.0.99-1.fc10,knetworkmanager-0.7-0.8.20080926svn.fc10,NetworkManager-vpnc-0.7.0.99-1.fc10,NetworkManager-openvpn-0.7.0.99-1.fc10,NetworkManager-pptp-0.7.0.99-1.fc10,NetworkManager-openconnect-0.7.0.99-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/NetworkManager-0.7.0.99-1.fc10,knetworkmanager-0.7-0.8.20080926svn.fc10,NetworkManager-vpnc-0.7.0.99-1.fc10,NetworkManager-openvpn-0.7.0.99-1.fc10,NetworkManager-pptp-0.7.0.99-1.fc10,NetworkManager-openconnect-0.7.0.99-1.fc10

Comment 9 Fedora Update System 2009-03-06 17:51:21 UTC
NetworkManager-0.7.0.99-1.fc9,NetworkManager-vpnc-0.7.0.99-1.fc9,NetworkManager-openvpn-0.7.0.99-1.fc9,NetworkManager-pptp-0.7.0.99-1.fc9,NetworkManager-openconnect-0.7.0.99-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/NetworkManager-0.7.0.99-1.fc9,NetworkManager-vpnc-0.7.0.99-1.fc9,NetworkManager-openvpn-0.7.0.99-1.fc9,NetworkManager-pptp-0.7.0.99-1.fc9,NetworkManager-openconnect-0.7.0.99-1.fc9

Comment 10 Fedora Update System 2009-03-08 19:29:52 UTC
NetworkManager-0.7.0.99-1.fc9, NetworkManager-vpnc-0.7.0.99-1.fc9, NetworkManager-openvpn-0.7.0.99-1.fc9, NetworkManager-pptp-0.7.0.99-1.fc9, NetworkManager-openconnect-0.7.0.99-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2009-03-08 19:31:23 UTC
NetworkManager-0.7.0.99-1.fc10, knetworkmanager-0.7-0.8.20080926svn.fc10, NetworkManager-vpnc-0.7.0.99-1.fc10, NetworkManager-openvpn-0.7.0.99-1.fc10, NetworkManager-pptp-0.7.0.99-1.fc10, NetworkManager-openconnect-0.7.0.99-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.