This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 465715 - file conflict between kde-i18n-Arabic and kde-l10n-Arabic
file conflict between kde-i18n-Arabic and kde-l10n-Arabic
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kde-i18n (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
: 465716 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-05 19:33 EDT by Corentin Perard-Gayot
Modified: 2008-11-22 18:25 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-22 18:25:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
yum install of the conflicting packages (2.38 KB, text/plain)
2008-10-05 19:51 EDT, Jeroen van Meeuwen
no flags Details

  None (edit)
Description Corentin Perard-Gayot 2008-10-05 19:33:51 EDT
Description of problem:
file conflict between kde-i18n-Arabic-3.5.10-1.fc9.noarch and kde-l10n-Arabic-4.0.3-4.fc9.noarch

Version-Release number of selected component (if applicable):
kde-i18n-Arabic-3.5.10-1.fc9

How reproducible:
always

Steps to Reproduce:
1.try to install kde-i18n-Arabic with kde-l10n-Arabic installed
-or-try to install kde-l10n-Arabic with kde-i18n-Arabic installed
  
Actual results:
error : file conflict for the file : /usr/share/locale/ar/LC_MESSAGES/kcmlilo.mo

Expected results:
package install


Additional info:
I got the error trying to install a fedora unity's respin on testing purpose.
Comment 1 Kevin Kofler 2008-10-05 19:45:25 EDT
I'm afraid there isn't much we can do about this. The Arabic KDE translation team wasn't able to keep their translation up to date and complete for KDE 4.1, so it was dropped, and so we can't update it anymore, and in particular we can't fix it to produce no conflicts with our updated kde-i18n packages.

Maybe it would be best to just exclude the dead kde-l10n-Arabic (and all the other kde-l10n-* stuff which has no 4.1.x version available, this affects a few other languages) from the respins? Putting an exclude=kde-l10n-* on the Everything repo (i.e. only allowing kde-l10n-* stuff from updates) should work.

It's too bad such a commonly-spoken language as Arabic doesn't have a more active translation team at upstream KDE.
Comment 2 Kevin Kofler 2008-10-05 19:48:05 EDT
*** Bug 465716 has been marked as a duplicate of this bug. ***
Comment 3 Jeroen van Meeuwen 2008-10-05 19:51:04 EDT
Created attachment 319511 [details]
yum install of the conflicting packages

Unable to reproduce on an updated fedora 9 station, log attached
Comment 4 Jeroen van Meeuwen 2008-10-05 19:59:13 EDT
(In reply to comment #1)
> I'm afraid there isn't much we can do about this. The Arabic KDE translation
> team wasn't able to keep their translation up to date and complete for KDE 4.1,
> so it was dropped, and so we can't update it anymore, and in particular we
> can't fix it to produce no conflicts with our updated kde-i18n packages.
> 

Besides the upstream Arabic KDE translation issue, can you update the package so that it doesn't conflict anymore? Either one could obsolete the other, one could no longer provide the conflicting file, ... ?
Comment 5 Kevin Kofler 2008-10-05 20:20:20 EDT
All the kde-l10n-* packages are built from a single SRPM which expects a single version to build, not some 4.1 and some 4.0 stuff.
Comment 6 Kevin Kofler 2008-10-30 08:39:35 EDT
See http://i18n.kde.org/stats/gui/stable-kde4/team/ar/ for the sad state of affairs the Arabic translation is in for KDE 4.1.
Comment 7 Jeroen van Meeuwen 2008-10-30 08:44:29 EDT
Again I recognize there is trouble upstream but that doesn't justify deferring a packaging issue on our side, IMHO.
Comment 8 Kevin Kofler 2008-10-30 08:49:51 EDT
kde-l10n-Arabic comes from an old SRPM, it can't be built from the current one because upstream dropped it from their current releases. The only safe thing to do is to uninstall it, resp. to exclude it from respins. The package is to effectively consider dropped.
Comment 9 Kevin Kofler 2008-10-30 09:01:56 EDT
The ONLY way you can get this fixed is by getting a team of Arabic translators to work on the upstream translations so they can get reincluded in a later release (but it's too late for 4.1.3 already and there probably won't be another release before 4.2.0).
Comment 10 Rex Dieter 2008-10-30 10:38:59 EDT
If there's no upgrade path, then the old, now awol pkg needs to be EOL'd and Obsoletes'd somewhere (kdelibs?).

In the meantime, kcmlilo.mo can/should be omitted from kde-i18n anyway, (it's not used anywhere... or is it?)
Comment 11 Steven M. Parrish 2008-11-22 18:25:10 EST
Since this is an upstream issue which is not and may not be addressed any time in the foreseeable future, going to close this as WONTFIX

Note You need to log in before you can comment on or make changes to this bug.