Bug 465719 - UnboundLocalError variable 'dev' in network.py 529
UnboundLocalError variable 'dev' in network.py 529
Status: CLOSED DUPLICATE of bug 465127
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity urgent
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-05 21:51 EDT by Chris Hubick
Modified: 2008-10-06 09:50 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-06 09:50:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda 11.4.1.40 exception report (132.52 KB, text/plain)
2008-10-05 21:51 EDT, Chris Hubick
no flags Details

  None (edit)
Description Chris Hubick 2008-10-05 21:51:38 EDT
Created attachment 319514 [details]
anaconda 11.4.1.40 exception report 

While installing Fedora 10 beta 1, after resolving dependencies, Anaconda crashes with a traceback in file "/usr/lib/anaconda/network.py", line 529, "in write" ... "if dev.get('GATEWAY'):"  UnboundLocalError: local variable 'dev' referenced before assignment.

I searched for these symptoms and found a single document being the attached pastebin output someone else had posted with what appears to be largely identical output to the problem I am having.

This occurs in both text and graphical modes.  I tried passing manual IP configuration to the kernel, noipv4/6, all to no avail.

The machine is a Panasonic CF-U1 laptop/netbook, currently with no ethernet card/dock and only wireless (Intel 5100).

Thanks for any assistance!
Comment 1 David Robinson 2008-10-06 07:24:33 EDT
I'm having this same problem (but wasn't able to capture any more information unfortunately), and I suspect its due to not having an Ethernet card (or in my case, having an intel nic that is susceptible to bz 459202).

I've had a quick look at the source code (network.py). The 'write' function doesn't handle cases where there are no nics (which causes dev to be undefined).
Comment 2 Chris Lumens 2008-10-06 09:50:30 EDT

*** This bug has been marked as a duplicate of bug 465127 ***

Note You need to log in before you can comment on or make changes to this bug.