Bug 465729 - Plugin for Network UPS Tools (NUT) is missing
Plugin for Network UPS Tools (NUT) is missing
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: collectd (Show other bugs)
14
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alan Pevec
Fedora Extras Quality Assurance
: Reopened
Depends On: 691380
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-06 01:19 EDT by George Notaras
Modified: 2011-05-03 00:51 EDT (History)
5 users (show)

See Also:
Fixed In Version: collectd-4.10.3-2.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-02 18:30:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description George Notaras 2008-10-06 01:19:26 EDT
The plugin for the Network UPS Tools (NUT) is missing from the collectd package.

This probably happens due to build problems, but I guess it has to be resolved somehow.

Version-Release number of selected component (if applicable):
collectd-4.4.3-2.fc9.i386
Comment 1 Fedora Update System 2008-11-30 09:08:10 EST
collectd-4.5.1-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/collectd-4.5.1-2.fc10
Comment 2 Fedora Update System 2008-11-30 09:08:15 EST
collectd-4.5.1-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/collectd-4.5.1-1.fc9
Comment 3 Fedora Update System 2008-12-02 20:15:21 EST
collectd-4.5.1-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update collectd'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-10549
Comment 4 Fedora Update System 2008-12-02 20:28:54 EST
collectd-4.5.1-2.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update collectd'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2008-10698
Comment 5 Fedora Update System 2008-12-07 16:36:20 EST
collectd-4.5.1-2.1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/collectd-4.5.1-2.1.fc9
Comment 6 Fedora Update System 2008-12-07 16:36:24 EST
collectd-4.5.1-2.1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/collectd-4.5.1-2.1.fc10
Comment 7 Fedora Update System 2008-12-09 06:35:35 EST
collectd-4.5.1-2.1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update collectd'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-11042
Comment 8 Fedora Update System 2008-12-09 06:39:00 EST
collectd-4.5.1-2.1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update collectd'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2008-11067
Comment 9 Fedora Update System 2008-12-21 03:20:29 EST
collectd-4.5.1-2.1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2008-12-21 03:45:00 EST
collectd-4.5.1-2.1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Alan Pevec 2011-03-29 08:35:48 EDT
fc14 and later have nut 2.6 which breaks collectd check:
  libupsclient  . . . . no (symbol upscli_connect not found)
Comment 12 Alan Pevec 2011-03-29 11:56:32 EDT
Michal, any ideas what changed in nut 2.6 to make collectd configure-time check fail.
AFAICT, there wasn't soname change, so API shouldn't have changed?
Comment 13 Michal Hlavinka 2011-03-29 12:15:01 EDT
I can see there are new successful builds in koji, so is problem solved already?
Old failures were probably caused by bug #691380
Comment 14 Alan Pevec 2011-03-29 12:27:58 EDT
I disabled nut plugin, b/c scratch build for f14 with nut enabled failed the same.
Seems that fix for bug #691380 didn't reach f14/15 buildroots?
Comment 15 Michal Hlavinka 2011-04-04 06:17:15 EDT
right, they were just built, but not pushed to updates(-testing). I've submitted them for testing in bodhi right now, so they should get to buildroot soon.
Comment 16 Fedora Update System 2011-04-19 18:48:20 EDT
collectd-4.10.3-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/collectd-4.10.3-2.fc15
Comment 17 Fedora Update System 2011-04-19 22:44:25 EDT
Package collectd-4.10.3-2.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing collectd-4.10.3-2.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/collectd-4.10.3-2.fc15
then log in and leave karma (feedback).
Comment 18 Fedora Update System 2011-04-20 04:42:54 EDT
collectd-4.9.5-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/collectd-4.9.5-2.fc14
Comment 19 Fedora Update System 2011-05-02 18:29:54 EDT
collectd-4.9.5-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 20 Fedora Update System 2011-05-03 00:51:11 EDT
collectd-4.10.3-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.