This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 691380 - Wrong entry @LIBSSL_LDFLAGS@ in libupsclient.pc pkgconfig file
Wrong entry @LIBSSL_LDFLAGS@ in libupsclient.pc pkgconfig file
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nut (Show other bugs)
rawhide
Unspecified Linux
unspecified Severity medium
: ---
: ---
Assigned To: Michal Hlavinka
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 465729 690558
  Show dependency treegraph
 
Reported: 2011-03-28 08:04 EDT by Anton Guda
Modified: 2011-04-19 14:28 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-28 09:12:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Anton Guda 2011-03-28 08:04:39 EDT
Description of problem:
Macro @LIBSSL_LDFLAGS@ in libupsclient.pc pkgconfig file is not converted to real linker flags (for example, ' -lssl -lcrypto -ldl -lz '). So, build of dependent packages (collectd) will fail.


Version-Release number of selected component (if applicable):
nut-2.6.0-3

How reproducible:
Always


Steps to Reproduce:
1. look at /usr/lib/pkgconfig/libupsclient.pc -- see macros
2. try to build collectd - failed
  
Actual results:
see above

Expected results:
macro is expanded to real linker flags, builds ok.


Additional info:
For now I made a workaround in spec file (install section):

pushd ${RPM_BUILD_ROOT}%{_libdir}/pkgconfig
sed -i.orig -e 's/@LIBSSL_LDFLAGS@/ -lssl -lcrypto -ldl -lz /' libupsclient.pc 
rm *.orig
popd

I know, it's bad hack, as binded to one arch. But works for me.

Note You need to log in before you can comment on or make changes to this bug.