Bug 465760 - modeset kernel: [drm:radeon_mem_init_heap] *ERROR* heap already initialized?
Summary: modeset kernel: [drm:radeon_mem_init_heap] *ERROR* heap already initialized?
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati
Version: rawhide
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Dave Airlie
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-10-06 09:42 UTC by Mads Kiilerich
Modified: 2008-11-11 10:11 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-11-11 10:11:14 UTC
Type: ---


Attachments (Terms of Use)
Xorg.0.log from comment #5 (109.18 KB, application/octet-stream)
2008-10-23 12:56 UTC, Mads Kiilerich
no flags Details

Description Mads Kiilerich 2008-10-06 09:42:50 UTC
Description of problem:

System works, but when running glxgears or enabling compiz then it crashes short time after.

Kernel messages like these are logged:
[drm:radeon_cp_dispatch_texture] *ERROR* EFAULT on pad, 45056 bytes

[drm:radeon_mem_init_heap] *ERROR* heap already initialized?
mtrr: base(0xc49b6000) is not aligned on a size(0xb13000) boundary


Version-Release number of selected component (if applicable):

kernel-2.6.27-0.391.rc8.git7.fc10.i686
xorg-x11-drv-radeonhd-1.2.1-3.9.20080917git.fc10.i386


Same system as in bug 465331, but compiz works and nomodeset seems to not be needed anymore.


How reproducible:

yes, on my machine

Comment 1 Mads Kiilerich 2008-10-06 09:50:40 UTC
By "crashing" I mean "it hangs". Mouse can move, but keyboard (and capslock) doesn't work.

I can ssh to the machine and see the following top:

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND
 2777 root      20   0  155m  28m 7724 R 175.6  1.4   3:36.97 Xorg
 2558 root      20   0  3624 1036  916 D 81.1  0.1   2:01.99 hald-addon-stor

Comment 2 Hans Ulrich Niedermann 2008-10-12 23:44:15 UTC
Is this issue still appearing with 2.6.27-2.fc10 or later?

Comment 3 Mads Kiilerich 2008-10-13 11:12:17 UTC
I was just about to report back that Desktop Effects worked and glxgears worked fine. (Glxgears did however use a lot of cpu - I thought that it would use hardware acceleration ... but the card/driver has perhaps only 2d acceleration ... never mind.)

BUT then it hang again, just like before.

kernel-2.6.27-3.fc10.i686 with nomodeset
xorg-x11-drv-radeonhd-1.2.1-3.9.20080917git.fc10.i386

strace shows that xorg loops doing
--- SIGALRM (Alarm clock) @ 0 (0) ---
sigreturn()                             = ? (mask now [])
ioctl(11, 0xc0286429, 0xbfa8ba74)       = -1 EBUSY (Device or resource busy)
--- SIGALRM (Alarm clock) @ 0 (0) ---
sigreturn()                             = ? (mask now [])
ioctl(11, 0xc0286429, 0xbfa8ba74)       = -1 EBUSY (Device or resource busy)

with
lrwx------ 1 root root 64 2008-10-13 12:51 /proc/3181/fd/11 -> /dev/dri/card0

And the kernel has two reports of
Oct 13 12:42:20 dev-mk kernel: [drm:radeon_cp_dispatch_texture] *ERROR* EFAULT on pad, 36864 bytes
and 30 of
Oct 13 12:42:21 dev-mk kernel: [drm:radeon_cp_dispatch_texture] *ERROR* EFAULT on pad, 45056 bytes

Nothing interesting in X logs.

(By the way: Is there a good way to start X in "safe mode" so that Desktop Effects isn't started even tough it is configured?)

Comment 4 Mads Kiilerich 2008-10-14 12:22:04 UTC
Actually, this bug is with radeon_drv.so, just like bug 466437. Sorry for the confusion.

And to make it clear: compiz "works" for half a second, then the system hangs.

Comment 5 Mads Kiilerich 2008-10-23 12:49:03 UTC
With
xorg-x11-drv-ati-6.9.0-29.fc10.i386
kernel-2.6.27.3-34.rc1.fc10.i686
running without nomodeset

I just got
Oct 23 14:43:56 dev-mk kernel: [drm:radeon_mem_init_heap] *ERROR* heap already initialized?
Oct 23 14:43:56 dev-mk kernel: mtrr: base(0xc2875000) is not aligned on a size(0xb13000) boundary
Oct 23 14:44:07 dev-mk acpid: client connected from 2619[0:0]
Oct 23 14:44:15 dev-mk kernel: mtrr: base(0xc18b4000) is not aligned on a size(0x6ec000) boundary

It might be related to that I was testing fast user switching around that time.

Comment 6 Mads Kiilerich 2008-10-23 12:50:33 UTC
Re comment #5: I forgot to mention that AFAIK I was NOT using desktop effects or other GL stuff.

Comment 7 Mads Kiilerich 2008-10-23 12:56:26 UTC
Created attachment 321277 [details]
Xorg.0.log from comment #5

Comment 8 Mads Kiilerich 2008-11-11 10:11:14 UTC
Can't reproduce and much has changed since this report. Closing.


Note You need to log in before you can comment on or make changes to this bug.