Bug 465844 - X startup failed during install
X startup failed during install
Status: CLOSED DUPLICATE of bug 461829
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-06 13:32 EDT by David
Modified: 2008-10-20 10:18 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-20 10:18:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
requested X.log (20.67 KB, text/plain)
2008-10-06 15:17 EDT, David
no flags Details

  None (edit)
Description David 2008-10-06 13:32:41 EDT
Description of problem:
Fc10-Beta graphical install fails with this message:
"X startup failed, falling back to text mode"

Version-Release number of selected component (if applicable):


How reproducible:
Every time.

Steps to Reproduce:
1.Try graphical install.

Actual results:
X startup fails

Expected results:
X startup doesn't fail


Additional info:
Smolt profile:
http://www.smolts.org/client/show/pub_a3054051-efb5-405b-b00c-637384992428
Comment 1 Chris Lumens 2008-10-06 13:40:08 EDT
Please attach /tmp/X.log to this bug report.  Thanks.
Comment 2 David 2008-10-06 15:17:47 EDT
Created attachment 319593 [details]
requested X.log
Comment 3 David 2008-10-06 15:24:01 EDT
I should mention that X has been working horribly on this system since f9.
X crashes about once per week in f9.  But in f10beta, X just doesn't work
at all during installation.  Here's another bug report for X on the same
system:

https://bugzilla.redhat.com/show_bug.cgi?id=449460

As far as I know, there isn't a hardware problem, because it worked fine
in f8.
Comment 4 David 2008-10-19 10:16:35 EDT
Is this bug the same as this?:

https://bugzilla.redhat.com/show_bug.cgi?id=461829

The end of the X.log looks similar... both have this:

(EE) intel(0): Failed to pin front buffer: Cannot allocate memory

Fatal server error:
Couldn't bind memory for BO front buffer
Comment 5 Matěj Cepl 2008-10-20 10:18:48 EDT
You are probably right. Closing this as duplicate.

*** This bug has been marked as a duplicate of bug 461829 ***

Note You need to log in before you can comment on or make changes to this bug.