Bug 465855 - perl-libwww-perl: should provide /usr/bin/{HEAD,GET,POST}
perl-libwww-perl: should provide /usr/bin/{HEAD,GET,POST}
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: perl-libwww-perl (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Stepan Kasal
Fedora Extras Quality Assurance
:
: 465853 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-06 14:08 EDT by Jose Pedro Oliveira
Modified: 2008-10-13 05:52 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-09 17:32:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Restores the missing files (571 bytes, patch)
2008-10-06 14:19 EDT, Jose Pedro Oliveira
no flags Details | Diff

  None (edit)
Description Jose Pedro Oliveira 2008-10-06 14:08:54 EDT
Description of problem:
The latest version of perl-libwww-perl (5.814) doesn't include the files
/usr/bin/{HEAD,GET,POST}.  All previous versions installed them.

Version-Release number of selected component (if applicable):
perl-libwww-perl-5.814-2.fc10

How reproducible:
Always


  
Actual results:
The perl-libwww-perl shipped with Fedora 9 included the mentioned files.
The Fedora 9 perl-libwww-perl update removes them.
The rawhide perl-libwww-perl version no longer includes them.


Expected results:
Restore the missing files.

Additional info:

$ rpm -qpl releases/9/Everything/i386/os/Packages/perl-libwww-perl-5.808-7.fc9.noarch.rpm | sort | head
/usr/bin/GET
/usr/bin/HEAD
/usr/bin/lwp-download
/usr/bin/lwp-mirror
/usr/bin/lwp-request
/usr/bin/lwp-rget
/usr/bin/POST
/usr/lib/perl5/vendor_perl/5.10.0/Bundle
/usr/lib/perl5/vendor_perl/5.10.0/Bundle/LWP.pm
/usr/lib/perl5/vendor_perl/5.10.0/File


$ rpm -qpl updates/9/i386.newkey/perl-libwww-perl-5.814-3.fc9.noarch.rpm | sort | head
/usr/bin/lwp-download
/usr/bin/lwp-mirror
/usr/bin/lwp-request
/usr/bin/lwp-rget
/usr/lib/perl5/vendor_perl/5.10.0/Bundle
/usr/lib/perl5/vendor_perl/5.10.0/Bundle/LWP.pm
/usr/lib/perl5/vendor_perl/5.10.0/File
/usr/lib/perl5/vendor_perl/5.10.0/File/Listing.pm
/usr/lib/perl5/vendor_perl/5.10.0/HTML
/usr/lib/perl5/vendor_perl/5.10.0/HTML/Form.pm


$ rpm -qpl development/i386/os/Packages/perl-libwww-perl-5.814-2.fc10.noarch.rpm  | sort | head
/usr/bin/lwp-download
/usr/bin/lwp-mirror
/usr/bin/lwp-request
/usr/bin/lwp-rget
/usr/lib/perl5/vendor_perl/5.10.0/Bundle
/usr/lib/perl5/vendor_perl/5.10.0/Bundle/LWP.pm
/usr/lib/perl5/vendor_perl/5.10.0/File
/usr/lib/perl5/vendor_perl/5.10.0/File/Listing.pm
/usr/lib/perl5/vendor_perl/5.10.0/HTML
/usr/lib/perl5/vendor_perl/5.10.0/HTML/Form.pm


NOTE: The F9 update release is newer than the rawhide one.
Comment 1 Jose Pedro Oliveira 2008-10-06 14:17:26 EDT
The new upstream Makefile.PL supports the --aliases option that allows us to install the mentioned files.

Source:
http://search.cpan.org/diff?from=libwww-perl-5.808&to=libwww-perl-5.814#Makefile.PL
Comment 2 Jose Pedro Oliveira 2008-10-06 14:19:28 EDT
Created attachment 319583 [details]
Restores the missing files
Comment 3 Jose Pedro Oliveira 2008-10-06 14:21:54 EDT
FYI: The latest upstream version is 5.816.

CPAN homepage:
http://search.cpan.org/dist/libwww-perl/

Diff from 5.814 to 5.816:
http://search.cpan.org/diff?from=libwww-perl-5.814&to=libwww-perl-5.816
Comment 4 David Rees 2008-10-06 22:32:07 EDT
This affects Fedora 9 as well and is a serious regression. It has broken applications which depend on those scripts to be there.
Comment 5 Marcela Mašláňová 2008-10-07 04:29:27 EDT
*** Bug 465853 has been marked as a duplicate of this bug. ***
Comment 6 Fedora Update System 2008-10-07 06:41:07 EDT
perl-libwww-perl-5.816-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/perl-libwww-perl-5.816-1.fc9
Comment 7 David Rees 2008-10-07 15:46:52 EDT
Latest build fixes this bug for me for Fedora 9.
Comment 8 Fedora Update System 2008-10-09 17:32:12 EDT
perl-libwww-perl-5.816-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Jose Pedro Oliveira 2008-10-12 11:28:22 EDT
Marcela, 

Thanks for the update. 

Just a note about the changelog entry:

   "- fix #465855 - add --aliases into INSTALLDIRS"

This entry is misleading. To be precise "--aliases" is a command line option of the script Makefile.PL while INSTALLDIRS is an ExtUtils::MakeMaker variable. They aren't related as the changelog entry suggests.

/jpo

PS - Version 5.8.17 is already available in CPAN:
     http://search.cpan.org/diff?from=libwww-perl-5.816&to=libwww-perl-5.817
Comment 10 Marcela Mašláňová 2008-10-13 05:52:06 EDT
Thanks.
Updated in rawhide.

Note You need to log in before you can comment on or make changes to this bug.