Bug 465883 - Need Obsoletes in the kernel package for gfs2-kmod
Need Obsoletes in the kernel package for gfs2-kmod
Status: CLOSED DUPLICATE of bug 460047
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Chris Feist
Martin Jenner
:
: 463983 467013 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-06 18:47 EDT by Chris Feist
Modified: 2009-01-12 16:12 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-03 09:42:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to obsolete kmod-gfs2 (1.53 KB, patch)
2008-10-24 19:29 EDT, Chris Feist
no flags Details | Diff

  None (edit)
Description Chris Feist 2008-10-06 18:47:32 EDT
The gfs2-kmod package is not longer necessary in RHEL 5.3 and beyond (and was Tech Preview in 5.2 and earlier).

I think the best solution to make sure our users aren't using old and outdated versions of gfs2-kmod it to add an obsoletes to the kernel package to make sure any versions that the user has on their system will be uninstalled upon installation of the new kernel that contains the in kernel gfs2 module.

Please let me know if that won't work, or there are other things that we need to do.

Thanks!
Chris
Comment 1 RHEL Product and Program Management 2008-10-07 09:57:26 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 2 Steve Whitehouse 2008-10-15 04:15:31 EDT
*** Bug 467013 has been marked as a duplicate of this bug. ***
Comment 3 Alexander Todorov 2008-10-15 06:07:53 EDT
Steve,
wrt your comment at:
https://bugzilla.redhat.com/show_bug.cgi?id=467013#c2

> There is no new version of the gfs2-kmod, it doesn't exist any more as such.
> Its empty so there ought to be no conflicts.


There is a package : kmod-gfs2-1.116-1.14.el5.ia64.rpm in the latest build and:

$ rpm -qpl kmod-gfs2-1.116-1.14.el5.ia64.rpm 
/etc/depmod.d/gfs2.conf


The package has one file which is the conflicting file described in bug 467013.
Comment 4 Alexander Todorov 2008-10-15 06:09:48 EDT
(In reply to comment #0)
> The gfs2-kmod package is not longer necessary in RHEL 5.3 and beyond (and was
> Tech Preview in 5.2 and earlier).
> 
> I think the best solution to make sure our users aren't using old and outdated
> versions of gfs2-kmod it to add an obsoletes to the kernel package to make sure
> any versions that the user has on their system will be uninstalled upon
> installation of the new kernel that contains the in kernel gfs2 module.
> 

What about new versions of kmod-gfs2 package? Should they not exist at all? Please specify what's the desired behavior. Thanks.
Comment 5 Chris Feist 2008-10-15 16:13:43 EDT
No, all gfs2 kernel modules should be included with the standard Red Hat kernel.  We just want to make sure that the users don't have any of the tech preview gfs2-kmod packages installed because they will override the newer in kernel gfs2 modules.
Comment 6 Chris Feist 2008-10-15 16:16:00 EDT
*** Bug 463983 has been marked as a duplicate of this bug. ***
Comment 7 Alexander Todorov 2008-10-16 02:37:00 EDT
Chris,
what about the kmod-gfs2 rpm itself? I understand that the kernel module is now included in the kernel rpm and it will obsolete older versions of kmod-gfs2.rpm.
What is left is /etc/depmod.d/gfs2.conf. Does it stay in kmod-gfs2 rpm package?

Thanks!
Comment 8 Chris Feist 2008-10-16 16:52:59 EDT
that file is only needed if you need the kmod-gfs2 rpm package (so it will be removed when that package is removed).

Also, the obsoletes should obsolete any kmod-gfs2 that is older than 1.117, just in case it ever gets re-added in the future (I doubt it will, but it can't hurt to add that option).
Comment 9 Kiersten (Kerri) Anderson 2008-10-24 11:33:14 EDT
Chris, can you provide a spec file patch that obsoletes the correct versions of gfs2-kmod?
Comment 11 Chris Feist 2008-10-24 19:29:21 EDT
Created attachment 321478 [details]
Patch to obsolete kmod-gfs2

This path should fix the kernel .spec file to remove kmod-gfs2 during an upgrade.
Comment 12 Don Zickus 2008-10-24 19:39:48 EDT
Adding Jon Masters, as he was developing a more generic approach for this problem.  I'll let him comment directly.

Note You need to log in before you can comment on or make changes to this bug.