Bug 467013 - file conflict between old and new versions of gfs2-kmod packages
file conflict between old and new versions of gfs2-kmod packages
Status: CLOSED DUPLICATE of bug 465883
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.3
All Linux
medium Severity medium
: beta
: ---
Assigned To: Steve Whitehouse
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-15 03:06 EDT by Alexander Todorov
Modified: 2009-05-27 23:36 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-15 04:15:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2008-10-15 03:06:44 EDT
Description of problem:
Doing yum update against http repos or RHN fails with file conflict error:

Transaction Check Error:
  file /etc/depmod.d/gfs2.conf from install of kmod-gfs2-xen-1.116-1.14.el5 conflicts with file from package kmod-gfs2-1.92-1.1.el5
  file /etc/depmod.d/gfs2.conf from install of kmod-gfs2-xen-1.116-1.14.el5 conflicts with file from package kmod-gfs2-xen-1.92-1.1.el5
  file /etc/depmod.d/gfs2.conf from install of kmod-gfs2-1.116-1.14.el5 conflicts with file from package kmod-gfs2-1.92-1.1.el5
  file /etc/depmod.d/gfs2.conf from install of kmod-gfs2-1.116-1.14.el5 conflicts with file from package kmod-gfs2-xen-1.92-1.1.el5


Version-Release number of selected component (if applicable):
kmod-gfs2-1.116-1.14.el5
kmod-gfs2-xen-1.116-1.14.el5

How reproducible:
Always

Steps to Reproduce:
1. Install the system with RHEL 5.2, gfs2-kmod{-xen} included
2. Run yum update against RHN or http repository
3.
  
Actual results:
File conflict, yum error.

Expected results:
No errors, upgrade works.

Additional info:
Could be related to bug #463983
Comment 2 Steve Whitehouse 2008-10-15 04:15:31 EDT
There is no new version of the gfs2-kmod, it doesn't exist any more as such. Its empty so there ought to be no conflicts.

*** This bug has been marked as a duplicate of bug 465883 ***

Note You need to log in before you can comment on or make changes to this bug.