Bug 465985 - junit4: new version needed
junit4: new version needed
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: junit4 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Walluck
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 319161
  Show dependency treegraph
 
Reported: 2008-10-07 11:58 EDT by Jerry James
Modified: 2008-10-27 17:08 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-27 16:57:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jerry James 2008-10-07 11:58:45 EDT
Description of problem:
I am trying to update PMD in rawhide.  However, the latest PMD release requires JUnit 4.4, while we ship 4.3.1.  This is a hard dependency: PMD uses classes that exist in JUnit 4.4 and do not exist in JUnit 4.3.1.  I see that JUnit 4.5 was released 2 months ago, so we might want to upgrade straight to the latest version.

Version-Release number of selected component (if applicable):
junit4-4.3.1-1jpp.1.fc8

How reproducible:
N/A

Steps to Reproduce:
1. N/A
  
Actual results:
N/A

Expected results:
N/A

Additional info:
I am available to help with the JUnit upgrade if needed.
Comment 1 Fernando Nasser 2008-10-20 10:25:27 EDT
David, upstream has a 4.4, so merging it from JPackage and building it here will solve thhe current ptoblem.  If we have time left, a junit 4.5 seems to be a great idea for both here and upstream, but get the 4.4 in first to make sure we get it in time. Thanks!
Comment 2 David Walluck 2008-10-23 14:05:40 EDT
junit 4.4 and later introduces a dependency on hamcrest which is not in Fedora. The hamcrest package also has its own dependencies (some of which are also not in Fedora).
Comment 3 Jerry James 2008-10-27 16:43:28 EDT
Bummer.  Well, since pmd is stuck until junit can go forward, I'm motivated to work on those dependencies.  Are you interested in pushing any of them forward?  If so, perhaps we should chat via email about who wants to take what.  Thanks.
Comment 4 David Walluck 2008-10-27 16:57:49 EDT
I built hamcrest into rawhide with reduced options. Therefore, junit4 4.5 is now in rawhide. I suggest upgrading pmd as soon as possible. Since the packages may not have hit the mirrors yet, you may still test and commit your changes by first building the hamcrest and junit4 packages from CVS.
Comment 5 Jerry James 2008-10-27 17:08:09 EDT
That is really great news.  Thank you very much for your efforts.

Note You need to log in before you can comment on or make changes to this bug.