Red Hat Bugzilla – Bug 465985
junit4: new version needed
Last modified: 2008-10-27 17:08:09 EDT
Description of problem:
I am trying to update PMD in rawhide. However, the latest PMD release requires JUnit 4.4, while we ship 4.3.1. This is a hard dependency: PMD uses classes that exist in JUnit 4.4 and do not exist in JUnit 4.3.1. I see that JUnit 4.5 was released 2 months ago, so we might want to upgrade straight to the latest version.
Version-Release number of selected component (if applicable):
Steps to Reproduce:
I am available to help with the JUnit upgrade if needed.
David, upstream has a 4.4, so merging it from JPackage and building it here will solve thhe current ptoblem. If we have time left, a junit 4.5 seems to be a great idea for both here and upstream, but get the 4.4 in first to make sure we get it in time. Thanks!
junit 4.4 and later introduces a dependency on hamcrest which is not in Fedora. The hamcrest package also has its own dependencies (some of which are also not in Fedora).
Bummer. Well, since pmd is stuck until junit can go forward, I'm motivated to work on those dependencies. Are you interested in pushing any of them forward? If so, perhaps we should chat via email about who wants to take what. Thanks.
I built hamcrest into rawhide with reduced options. Therefore, junit4 4.5 is now in rawhide. I suggest upgrading pmd as soon as possible. Since the packages may not have hit the mirrors yet, you may still test and commit your changes by first building the hamcrest and junit4 packages from CVS.
That is really great news. Thank you very much for your efforts.