Bug 319161 - New Version
New Version
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pmd (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Jerry James
Fedora Extras Quality Assurance
:
Depends On: 465985 465987 465989
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-04 16:08 EDT by Scott J Henson
Modified: 2009-01-14 19:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-14 19:00:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott J Henson 2007-10-04 16:08:13 EDT
PMD 4.0 has been released and it seems more capable.  Could you please upgrade?
 Thank you.
Comment 1 Jerry James 2008-01-22 23:54:35 EST
And 4.1 is now out, but requires JUnit 4.4, while we currently have 3.8.2 in the
main package and 4.3.1 in the junit4 package.  I'd welcome an upgrade to at
least version 3.8 of PMD, which fixes a bug that makes the parser choke on a
large number of my source files.
Comment 2 Bug Zapper 2008-05-13 23:19:43 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 petrosyan 2008-05-15 23:24:09 EDT
pmd-4.2.1 has been released upstream http://pmd.sourceforge.net/
Comment 4 Jerry James 2008-10-02 16:41:16 EDT
And now 4.2.3 is out.  Also, the jar manifest has a Class-Path entry that refers to jaxen-1.1-beta-7.jar, which doesn't exist on F9.  We have jaxen-1.1.jar.

Matt, if you don't have time to maintain this package, will you please take on a comaintainer or orphan the package so someone else can pick it up?  I'm willing to do either.
Comment 5 Matt Wringe 2008-10-02 16:53:21 EDT
ok, I have orphaned the packaged, if you could maintain it that would be great.

Thanks, and sorry for not having time to update this package.
Comment 6 Jerry James 2008-10-07 10:01:30 EDT
I've taken ownership and will get working on a new release.  Thanks, Matt!
Comment 7 Jerry James 2008-10-07 12:01:36 EDT
It turns out that the dependency on JUnit 4.4 is a hard one.  PMD uses JUnit classes that do not exist in 4.3.1.  I have filed bug #465985 to address this.
Comment 8 Jerry James 2008-10-07 12:15:38 EDT
The new PMD also requires jaxen 1.1.1, instead of the jaxen 1.1 that we currently ship.  I have filed bug #465987 to address this.
Comment 9 Jerry James 2008-10-07 12:27:16 EDT
And finally, the new PMD requires JavaCC 4.1 to generate some of the code, while we currently ship JavaCC 4.0.  I have filed bug #465989 to address this.
Comment 10 Jerry James 2009-01-14 19:00:45 EST
PMD 4.2.4 has just been built for Rawhide.  Please try it out and file a new bug if it fails to work correctly.  I do not plan to build it for F-9 or F-10, as it represents a significant change in the way PMD works, but it (or some later version) will appear in Fedora 11.

Note You need to log in before you can comment on or make changes to this bug.