Bug 465989 - javacc: New version needed
javacc: New version needed
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: javacc (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wringe
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 319161
  Show dependency treegraph
 
Reported: 2008-10-07 12:25 EDT by Jerry James
Modified: 2009-09-03 10:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-03 10:32:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Spec file for JavaCC 4.1 (5.72 KB, text/plain)
2008-10-22 11:20 EDT, Jerry James
no flags Details

  None (edit)
Description Jerry James 2008-10-07 12:25:39 EDT
Description of problem:
I am working on a new PMD release.  Version 4.2.3 of PMD needs JavaCC 4.1 to correctly generate its code.  (The PMD sources ship with Java code that was generated by a JavaCC 4.1 prerelease version, which I find a bit scary.)  We currently ship JavaCC 4.0.

Version-Release number of selected component (if applicable):
javacc-4.0-4jpp.4

How reproducible:
N/A

Steps to Reproduce:
1. N/A
  
Actual results:
N/A

Expected results:
N/A

Additional info:
I am willing to help out with the upgrade, if needed.
Comment 1 Jerry James 2008-10-22 11:20:57 EDT
Created attachment 321167 [details]
Spec file for JavaCC 4.1

Here is a spec file that makes the change to 4.1.  It also fixes a few unclean things in the current spec file; see the ChangeLog entry I added for details.
Comment 2 Jerry James 2008-11-25 16:51:04 EST
Matt, is there any hope of upgrading JavaCC soon?  I would like to push the PMD update out.  Please respond.
Comment 3 Bug Zapper 2008-11-25 22:38:13 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Matt Wringe 2008-12-03 19:58:12 EST
Updated and build in rawhide. If that works for you I can push an update for Fedora 10.

FYI, all my packages are open in devel for anyone to make changes since it usually takes me a while to get to some of these updates.
Comment 5 Jerry James 2009-04-30 11:28:57 EDT
Sorry, I must have missed the email on this bug during the December rush.  The new PMD is only in F-11+, so what you've done already is sufficient.  Thank you!

Note You need to log in before you can comment on or make changes to this bug.