Bug 466180 - evolution default sorting broken
evolution default sorting broken
Status: CLOSED DUPLICATE of bug 466431
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-08 17:43 EDT by Dave Maley
Modified: 2008-10-10 08:46 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-10 08:46:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot #1 (184.25 KB, image/png)
2008-10-08 17:44 EDT, Dave Maley
no flags Details
screenshot #2 (184.53 KB, image/png)
2008-10-08 17:44 EDT, Dave Maley
no flags Details
screenshot #3 (184.06 KB, image/png)
2008-10-08 17:44 EDT, Dave Maley
no flags Details

  None (edit)
Description Dave Maley 2008-10-08 17:43:04 EDT
Description of problem:
evo seems to want to push unread messages to the top, moving read messages below unread messages.


Version-Release number of selected component (if applicable):
evolution-2.24.0-2.fc10.x86_64


How reproducible:
every time


Steps to Reproduce:
1. goto folder w/ unread messages
2. select 1st unread message
3. goto different folder and back again
  
Actual results:
read message will now appear at bottom, below all unread messages


Expected results:
sorting doesn't change


Additional info:
* leave as default sort (ie. don't click any column headers)

I've also seen some strange sorting behavior in folders w/ mailing list archives which seems likely related.

I'll attach 3 screenshots:
- ss1.png == all unread
- ss2.png == 1st message read, others left unread
- ss3.png == messages re-ordered
***reproduction step #3 was performed between ss2.png and ss3.png***
Comment 1 Dave Maley 2008-10-08 17:44:10 EDT
Created attachment 319806 [details]
screenshot #1
Comment 2 Dave Maley 2008-10-08 17:44:32 EDT
Created attachment 319807 [details]
screenshot #2
Comment 3 Dave Maley 2008-10-08 17:44:58 EDT
Created attachment 319808 [details]
screenshot #3
Comment 4 Matthew Barnes 2008-10-10 08:46:24 EDT

*** This bug has been marked as a duplicate of bug 466431 ***

Note You need to log in before you can comment on or make changes to this bug.