Bug 466431 - After upgrade from F-9, mailboxes appear unsorted
After upgrade from F-9, mailboxes appear unsorted
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
: Reopened
: 466180 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-10 05:10 EDT by Nils Philippsen
Modified: 2009-08-01 14:02 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-01 14:02:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch against Fedora CVS (32.88 KB, patch)
2009-05-01 14:13 EDT, Stu Tomlinson
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 563954 None None None Never

  None (edit)
Description Nils Philippsen 2008-10-10 05:10:45 EDT
Description of problem:

After upgrading from F-9 (which has evolution-2.23, i.e. uses old-style summaries), all mailboxes appear unsorted. Before, they were sorted by the date/time messages appeared in the respective mailbox. I haven't changed away from whatever defaultz sort order was used for the mailboxes.

Version-Release number of selected component (if applicable):
evolution-2.24.0-2.fc10

How reproducible:
After upograding from F-9, or evolution-2.23 respectively.

Steps to Reproduce:
1. With evo 2.23/F-9 Have mailboxes on an IMAP server.
2. Upgrade to Rawhide/F-10 Beta
3. Start evolution
  
Actual results:
Summaries get converted, mailboxes are completely unsorted.

Expected results:
Summaries get converted, mailboxes are sorted as they were before.


Additional info:
I assume that this stems from the new-style sqlite-based summaries. I checked the sort order on a system I haven't upgraded and both there and on Rawhide, it is listed as "Custom". Perhaps the upgrade mechanism which converts the summaries should change the old "Custom" sort order (which in most cases(*) orders messages by date/time of reception) to "Received" which resembles the old behavior closest IMO.

(*): If you moved messages around between mailboxes, the old "Custom" sort order would sort them as "newest" (or bottom-most) in the new mailbox, "Received" will sort them as per their latest Received header.
Comment 1 Matthew Barnes 2008-10-10 08:46:24 EDT
*** Bug 466180 has been marked as a duplicate of this bug. ***
Comment 2 Matthew Barnes 2008-11-24 08:48:51 EST
*** Bug 472742 has been marked as a duplicate of this bug. ***
Comment 3 Bug Zapper 2008-11-25 22:44:17 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Anthony Symons 2009-01-12 00:51:50 EST
As mentioned in bug 472742, there appears to be many problems with v2.24.x of evolution. 

I am experiencing the following issues still on the current version 2.24.2:

Evolution taking a long time to filter new messages, even when there are none, each time it polls my mailbox.

Randomly some emails can not be read due to "unable to find message body in fetch request from server" (or something along those lines).

Randomly some emails will not display due to "message content too long, you can view this message unformatted, or in an external viewer" (or similar message).

Randomly one of the above emails with "too long" content became viewable, and had a quoted reply. The email format was html. The new content viewed OK, but the quoted content had all become right hand side justified.

"Failed to store inbox" error messages

"Failed to write temporaty file /home/ant/.evolution/<temp name>, argument length too long" messages, when composing an email.

Evolution packages installed are:

evolution-2.24.2-3.fc10.x86_64
evolution-perl-2.24.2-3.fc10.x86_64
evolution-webcal-2.23.91-1.fc10.x86_64
evolution-data-server-doc-2.24.2-1.fc10.x86_64
evolution-data-server-2.24.2-1.fc10.x86_64
evolution-data-server-devel-2.24.2-1.fc10.x86_64
evolution-help-2.24.2-3.fc10.x86_64
Comment 5 Anthony Symons 2009-01-12 01:58:09 EST
Its just started happened again, can confirm exact messages are:

"Unable to retrieve message
Could not find message body in FETCH response."

"Unable to retrieve message
Cannot get message with message ID 5475341: No such message available."

I kept getting one of these messages, trying to read any email, most of them the "Could not find message body" error. Evolution had to be re-started at this point before I could read any of my email.
Comment 6 Dave Maley 2009-04-21 14:49:13 EDT
this bug is still present in F11 beta/rawhide (evolution-2.26.1-2.fc11), mailboxes are still not being sorted properly.
Comment 7 Milan Crha 2009-04-22 10:02:20 EDT
Closing, as the upstream bug contains patches awaiting a review.
Comment 8 Stu Tomlinson 2009-05-01 14:10:14 EDT
Upstream patches have been committed to master, is there any chance we can have these patches included in Fedora 11 packages?

I have "backported" (the only difficulty was in the ChangeLog files) the patches to local builds and sorting now behaves as I expect. I will attach a patch against Fedora CVS that applies to the relevant packages.
Comment 9 Stu Tomlinson 2009-05-01 14:13:39 EDT
Created attachment 342137 [details]
Patch against Fedora CVS

This patch applies against Fedora CVS for evolution-data-server, evolution, evolution-exchange & evolution-mapi
Comment 10 Stu Tomlinson 2009-05-21 20:59:03 EDT
Re-opening in the hope my request for a backported fix might get some attention (even if it's a negative), I did provide a patch :-)

I hope this is the correct bugzilla etiquette. Leaving version on Fedora 10 as there is no Fedora 11 product in bugzilla yet.
Comment 11 Matthew Barnes 2009-05-21 21:29:37 EDT
Evolution 2.26.2 is in the Fedora 11 testing repo.  Try that first.
Comment 12 Stu Tomlinson 2009-05-22 11:24:43 EDT
These patches are not in evolution/eds 2.26.2, so the build in Fedora 11 testing repo still has incorrect sorting.

The patches attached earlier still apply to 2.26.2 (excluding the Fedora spec file bits).

Oddly, evolution-mapi 0.27.1 (included in GNOME 2.26.2) does include the patch for this, but it refuses to build against eds 2.26.2 anyway.
Comment 13 Matthew Barnes 2009-08-01 14:02:30 EDT
Patches cannot be applied to Fedora 11 because it breaks libcamel's ABI.

The fix is present in Fedora 12 / Rawhide.

Note You need to log in before you can comment on or make changes to this bug.